Bug 28341 - Exception with LZ4 for .NET (https://lz4net.codeplex.com)
Summary: Exception with LZ4 for .NET (https://lz4net.codeplex.com)
Status: RESOLVED DOWNSTREAM
Alias: None
Product: Runtime
Classification: Mono
Component: Interop ()
Version: 3.12.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Alexander Kyte
URL:
Depends on:
Blocks:
 
Reported: 2015-03-23 16:29 UTC by Fabien Comte
Modified: 2015-04-02 11:40 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DOWNSTREAM

Description Fabien Comte 2015-03-23 16:29:05 UTC
Hello, 
I got these exception running my application on mono (on Framework .Net it works fine) 
 Unhandled Exception: 
 System.TypeInitializationException: An exception was thrown by the type initializer for LZ4.LZ4Codec ---> System.NotSupportedException: No LZ4 compression service found 
 at LZ4.LZ4Codec..cctor () [0x00000] in <filename unknown>:0 

 Do you have any idea ?
Comment 1 Alexander Kyte 2015-03-24 11:07:54 UTC
Could you please attach a sample application which raises this exception?
Comment 2 Fabien Comte 2015-03-24 12:38:44 UTC
LZ4 team maybe have an explaination (see http://lz4net.codeplex.com/workitem/5)

I will prepare a sample application if it's not confirmed on their way.

Thank you.
Comment 3 Rodrigo Kumpera 2015-04-02 11:40:04 UTC
Close this one since this looks like a problem with the LZ4 library itself.

If you run into a test case that shows an issue with mono, please file another bug report so we can fix it. :)
Comment 4 Rodrigo Kumpera 2015-04-02 11:40:13 UTC
Close this one since this looks like a problem with the LZ4 library itself.

If you run into a test case that shows an issue with mono, please file another bug report so we can fix it. :)