Bug 28319 - MONO does not compile
Summary: MONO does not compile
Status: RESOLVED INVALID
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-23 04:42 UTC by thomai
Modified: 2015-03-23 07:36 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Complete build log (1.04 MB, application/octet-stream)
2015-03-23 04:42 UTC, thomai
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description thomai 2015-03-23 04:42:29 UTC
Created attachment 10452 [details]
Complete build log

I'm trying to compile mono (GIT HEAD, 6a74b1952ffc7ba4a5331bf1356c4035769f2480) but I end up with an compile error:

build/common/basic-profile-check.cs(40,30): error CS0117: `System.Version' does not contain a definition for `TryParse'
/usr/lib/mono/2.0/mscorlib.dll (Location of the symbol related to previous error)
build/common/basic-profile-check.cs(43,21): error CS0165: Use of unassigned local variable `version'
Compilation failed: 2 error(s), 0 warnings
Comment 1 Marek Safar 2015-03-23 05:22:54 UTC
That's expected. You are bootstrapping with too old mono, check how to compile mono
Comment 2 thomai 2015-03-23 07:36:59 UTC
I upgraded to 3.0.7, then to 3.12.1 and then it worked.

Thank you!