Bug 2820 - CoreAnimation Sample loses the 'Contents' button after selecting a 'UIView Animations' option
Summary: CoreAnimation Sample loses the 'Contents' button after selecting a 'UIView An...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.0
Hardware: PC Mac OS
: Low minor
Target Milestone: Untriaged
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2012-01-09 18:53 UTC by Eric Beisecker
Modified: 2014-01-24 09:36 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Eric Beisecker 2012-01-09 18:53:19 UTC
Current Behavior: While running the CoreAnimation sample application the 'Contents' button disappears after selecting any of the menu options that appear after clicking the 'Contents' options.

Expected Behavior: The 'Contents' button should always be visible. 

Versions: 
MonoDevelop 2.8.5
Runtime:
	Mono 2.10.8 (tarball Mon Dec 19 17:43:18 EST 2011)
	GTK 2.24.5
	GTK# (2.12.0.0)
Apple Developer Tools:
	 Xcode 4.2.1 (834)
	 Build 4D502
Monotouch: 5.0.5

To Reproduce: 

https://testrail.xamarin.com/index.php?/cases/view/2648
Comment 1 Sebastien Pouliot 2012-01-16 14:28:03 UTC
The `WillHideViewController` event, where the `AddContentsButton` is called, is not invoked when a new `detailView` is created. This results in the lack of button once a new detail view is selected. 

IOW this is a sample bug, not a monotouch bug (you're right it's minor :-)
Comment 2 Sebastien Pouliot 2012-01-16 15:04:53 UTC
Fixed in bd514103862eaba845143385527e33a99ecae407
Comment 3 narayanp 2014-01-24 09:36:59 UTC
I have checked this issue with following builds:

All Mac
X.S 4.2.3(build 154)
Mono 3.2.6
X.iOS 7.0.7.64

Now application working fine. Content button does not disappear after selecting any option. Checked it on both Simulator and iPad.