Bug 282 - incorrect width in TableLayoutPanel using AutoSize
Summary: incorrect width in TableLayoutPanel using AutoSize
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 2.10.x
Hardware: All All
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-12 10:49 UTC by expebition
Modified: 2017-09-22 11:21 UTC (History)
3 users (show)

Tags: mono-community
Is this bug a regression?: ---
Last known good build:


Attachments
test case project (12.60 KB, application/zip)
2011-08-12 10:49 UTC, expebition
Details
screenshot - .NET on top, Mono on bottom (Windows 7) (16.52 KB, image/png)
2011-08-12 10:52 UTC, expebition
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 282 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description expebition 2011-08-12 10:49:38 UTC
Created attachment 116 [details]
test case project

Description of Problem: Width properties are not computed correctly in dialogs using TableLayoutPanel with AutoSize set to True


Steps to reproduce the problem:
1. build attached test case
2. run with .NET
3. run with Mono


Actual Results:
.NET (top half of attached screenshot) properly displays two labels and two text boxes.  With Mono, only the first label and part of the first text box are visible on the form because the text box is too wide.

Expected Results:
Mono to properly display all columns of the TableLayoutPanel.

How often does this happen? 
100% of the time.

Additional Information:
A variation of this problem occurs with a two-column TableLayoutPanel, although in that case it is not obvious until the dialog width is adjusted using the mouse.

This is perhaps related to https://bugzilla.novell.com/show_bug.cgi?id=531591
Comment 1 expebition 2011-08-12 10:52:08 UTC
Created attachment 117 [details]
screenshot - .NET on top, Mono on bottom (Windows 7)
Comment 2 Thomas Goldstein 2011-11-28 15:19:30 UTC
More info on this bug: https://bugzilla.novell.com/show_bug.cgi?id=531591
Comment 3 Thomas Goldstein 2011-11-28 15:19:56 UTC
(Oops, missed the fact this was already mentioned)