Bug 28153 - Build Error - Microsoft.Build.Tasks.Copy.Execute () [0x0000] in <filename unknown>:0
Summary: Build Error - Microsoft.Build.Tasks.Copy.Execute () [0x0000] in <filename unk...
Status: CLOSED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-18 11:10 UTC by Dolphintnks
Modified: 2015-03-18 12:57 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Dolphintnks 2015-03-18 11:10:15 UTC
After updating a scrollview to AutoLayout in xcode the project will not build.  Here is the error:  


/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: /xxx/xxxx/xxxxxx/xxx.nib is a directory  at System.IO.File.Delete (System.String path) [0x00000] in <filename unknown>:0 
  at Microsoft.Build.Tasks.Copy.CopyFile (System.String source, System.String dest, Boolean create_dir) [0x00000] in <filename unknown>:0 
  at Microsoft.Build.Tasks.Copy.Execute () [0x00000] in <filename unknown>:0  (XXXXXX)

Any assistance would be much appreciated! 
Thank you.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-03-18 11:35:19 UTC
Please attach the full build log.
Comment 4 Dolphintnks 2015-03-18 12:01:52 UTC
Solved.
Comment 5 Ram Chandra 2015-03-18 12:57:30 UTC
As per comment 4. This issue has been resolved.

Hence, I am closing this issue.