Bug 28029 - Android slider view has an offset
Summary: Android slider view has an offset
Status: RESOLVED DUPLICATE of bug 29128
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.5
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-14 05:43 UTC by Maru
Modified: 2015-05-20 20:53 UTC (History)
4 users (show)

Tags: android functional slider
Is this bug a regression?: ---
Last known good build:


Attachments
Slider Bug (5.70 KB, image/jpeg)
2015-03-14 05:43 UTC, Maru
Details
Zip Xamarin Logs (540.42 KB, application/octet-stream)
2015-05-01 08:07 UTC, Sadik Ali
Details
Test Project (161.24 KB, application/octet-stream)
2015-05-01 08:08 UTC, Sadik Ali
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 29128

Description Maru 2015-03-14 05:43:24 UTC
Created attachment 10335 [details]
Slider Bug

Putting a "Slider" view into my app results in the slider having an offset from the actual button to move the slider. A picture is attached at the end.
Tested on Android emulator 4.1.1 and 4.3.

<AbsoluteLayout
    x:Name = "layout" >
    <Image
        x:Name = "backgroundImage"
        Source = "image.jpg"
        Aspect = "AspectFill"
        AbsoluteLayout.LayoutBounds = "0, 0, 1, 1"
                AbsoluteLayout.LayoutFlags = "All" />
       <Slider
        x:Name = "slider"
        BackgroundColor = "Black"
        Maximum = "20"
        Minimum = "5"
        Value = "5"
        AbsoluteLayout.LayoutBounds = "0, 1, 1, 0.15"
                AbsoluteLayout.LayoutFlags = "All" />
    <StackLayout 
        Orientation = "Horizontal" 
        BackgroundColor = "Black"
        Padding = "10, 0, 10, 0"
        AbsoluteLayout.LayoutBounds = "0, 1, 1, 0.05"
                AbsoluteLayout.LayoutFlags = "All" >
        <Label Text = "5" HorizontalOptions = "StartAndExpand" />
        <Label x:Name = "testLabel" Text = "10" HorizontalOptions = "CenterAndExpand" />
        <Label Text = "20" HorizontalOptions = "EndAndExpand" />
    </StackLayout>
</AbsoluteLayout>
Comment 1 Maru 2015-04-01 11:43:49 UTC
Wrapping the slider into a StackLayout fixes the problem.
Comment 2 Sadik Ali 2015-05-01 08:06:36 UTC
I have checked this issue and able to reproduce the above behavior with the help of code given in the bug description.I checked this issue on XAP Nexus4(KitKat).

Screencast: http://www.screencast.com/t/0Ls0A1eJ
Build Output: https://gist.github.com/saurabh360/eaa8611f065c8a824cb1
Debug Output: https://gist.github.com/saurabh360/e05c4ae5f8f2d17c09ab

Xamarin.Forms: 1.4.3.6358-pre2

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Professional

Xamarin   3.11.479.0 (9472bfb)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.0.115 (d23da369e436488f38c8ab8fe8a9ae7d9ea5256b)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 3 Sadik Ali 2015-05-01 08:07:30 UTC
Created attachment 11016 [details]
Zip Xamarin Logs
Comment 4 Sadik Ali 2015-05-01 08:08:07 UTC
Created attachment 11017 [details]
Test Project
Comment 5 Seth Rosetter 2015-05-20 20:53:58 UTC

*** This bug has been marked as a duplicate of bug 29128 ***