Bug 28010 - Reachability breaks if in a class library with LINK ALL
Summary: Reachability breaks if in a class library with LINK ALL
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: XI 8.8.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Paola Villarreal
URL:
Depends on:
Blocks:
 
Reported: 2015-03-13 11:08 UTC by Neal
Modified: 2015-03-22 17:59 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Testcase for bug. (2.35 MB, application/x-gzip)
2015-03-22 14:03 UTC, Paola Villarreal
Details
updated sample (25.57 KB, application/zip)
2015-03-22 17:59 UTC, Neal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Neal 2015-03-13 11:08:21 UTC
Hello,

I'm sorry I don't have a sample app to provide but this is a simple scenario.  Take the Reachability.cs class that you have on Github and place it in a class library referenced by an iOS app, unified or not, but I'm using unified.  In the iOS app set LINK ALL for the AdHoc or AppStore build as if you were sending this to production.  What I notice is that when LINK ALL is used reachability fails.  If I use LINK SDK ONLY then it will work.  As a result I don't have confidence in the LINK ALL but wanted to bring this to your attention.

Thank you.
Comment 1 Sebastien Pouliot 2015-03-16 10:20:35 UTC
@Paola can you create/attach a test case for this. Thanks!
Comment 2 Paola Villarreal 2015-03-18 13:55:31 UTC
On it!
Comment 3 Paola Villarreal 2015-03-22 14:03:22 UTC
Created attachment 10447 [details]
Testcase for bug.

This test is used to try to reproduce the reported behaviour.
Comment 4 Paola Villarreal 2015-03-22 14:04:58 UTC
Ok, added the test case and changed build config to LINK ALL but Reachability is still working (on device, using iOS 8.2).

Could you provide version info and/or confirm that you can reproduce the reported behaviour using the test case I just attached to this bug?

Thank you.
Comment 5 Neal 2015-03-22 17:59:14 UTC
Hi Paola,

The sample you created is not per what I outlined, I updated it to put reachability in a class library but cannot reproduce the issue.  I will try to create a working sample and if reproduced I'll reopen this case.

Thank you for your time.
Comment 6 Neal 2015-03-22 17:59:32 UTC
Created attachment 10449 [details]
updated sample