Bug 2786 - Incorrect file selected when cutting/pasting within the solution
Summary: Incorrect file selected when cutting/pasting within the solution
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Management ()
Version: Trunk
Hardware: PC Mac OS
: Low minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-09 06:19 UTC by Alan McGovern
Modified: 2017-08-22 21:59 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Alan McGovern 2012-01-09 06:19:57 UTC
Steps:
1) Create three directories, A, B and C
2) Create a file called "A.cs" in directory A and directory C
3) Right click on the A.cs in directory C, choose 'cut' and then paste it into directory B
4) MonoDevelop will now select the file A.cs in directory A instead of directory B.
Comment 2 Will Smith 2017-08-22 19:44:59 UTC
Thanks so much for taking the time to submit this report! I attempted to reproduce this issue based on the bug description with the latest Visual Studio 2017 for Mac Preview version 7.2, and I was unable to hit the problem. If this issue is still occurring for you, please reopen this report and attach a reproduction, ideally starting with a new template project and then adding just the code necessary to demonstrate the issue.
Comment 3 Attila Tamás Zimler 2017-08-22 21:59:03 UTC
I also retested it and in the past 5 years it seems somebody fixed it.