Bug 27807 - 64-bit application fails with condition `src_slot < 16' not met
Summary: 64-bit application fails with condition `src_slot < 16' not met
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 8.10
Assignee: Zoltan Varga
URL:
Depends on: 27878
Blocks:
  Show dependency tree
 
Reported: 2015-03-09 23:11 UTC by Michael Stonis
Modified: 2015-03-13 15:54 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-03-10 04:28:46 UTC
Can we get access to your project so that we can reproduce this ourselves?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-03-11 04:25:48 UTC
I can reproduce it.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2015-03-11 09:09:16 UTC
I can reproduce the crash with Xamarin.iOS 8.6.

However in XI/master we're crashing even earlier (bug #27878), so I can't say until that bug's fixed if this is already resolved or not.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2015-03-12 06:51:13 UTC
This still happens with maccore/master.

Zoltan, can you have a look?

Just use the same test case (and steps) as for bug #27878, and at startup tap "Create a New Account".
Comment 6 Zoltan Varga 2015-03-12 16:30:55 UTC
Fixed in mono-extensions 0f6e4549278e1ad367cab22404029bbac85fe777.

This can be a candidate for sr3 if its still open.
Comment 7 Rolf Bjarne Kvinge [MSFT] 2015-03-13 09:13:33 UTC
No, SR3 is closed now unless it's a regression..
Comment 8 Sebastien Pouliot 2015-03-13 10:22:20 UTC
SR3 ship has sailed, changing milestone to 8.10 for QA verification.
Comment 9 Michael Stonis 2015-03-13 10:23:54 UTC
Is there an ETA for 8.10? We have a client app that cannot go live until this is resolved.
Comment 10 Sebastien Pouliot 2015-03-13 10:30:33 UTC
ETA for 8.10: first public alpha next week, stable channel in mid-April
Comment 11 Zoltan Varga 2015-03-13 15:54:45 UTC
As a workaround, try reducing the number of parameters to the this.WhenAnyValue call
at CreateNewAccount.cs, line 236.