Bug 2780 - Drag-drop of file in solution pad does nothing
Summary: Drag-drop of file in solution pad does nothing
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.6
Hardware: PC Windows
: High major
Target Milestone: 2.8.7
Assignee: Mikayla Hutchinson [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-01-09 03:35 UTC by Nischal
Modified: 2013-05-24 07:15 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Nischal 2012-01-09 03:35:21 UTC
Steps to Reproduce:

1. Click on File >> New >> Solution.
2. Select C# >> Console Project.
3. Enter the name for the new solution in the Name text box.
4. Click forward button and then click on OK button.
5. Right click on Project Name and select Add >> New File.
6. Select Empty Class enter the name and click 'New'.
7. Right click on Project Name and select Add >> New Folder.
8. Click and hold on the New Class file and Drag it to the New Folder.
9. Observe that nothing happens.

Actual result: 

When click and hold on the New Class file and Drag it to the New Folder, nothing happens.

Expected result:

When click and hold on the New Class file and Drag it to the New Folder, then the file should display under New Folder and should be located in that folder in the disk.

Environment: 

Windows 7 (64-bit)
MonoDevelop 2.8.6
Mono for Android 4.0.2
Comment 1 Nischal 2012-01-09 03:39:15 UTC
This bug is logged against the test case ID: T23639, the link for the same is mentioned below:
https://testrail.xamarin.com/index.php?/tests/view/23639
Comment 2 Mikayla Hutchinson [MSFT] 2012-01-09 13:40:45 UTC
I can reproduce this, will investigate.
Comment 3 Mikayla Hutchinson [MSFT] 2012-01-10 15:51:06 UTC
Fixed in master.
Comment 4 Nischal 2013-05-24 07:15:52 UTC
Today we have checked this issue on following builds :

Windows 7 / 8 
MonoDevelop 4.0.7 (build 3)
Xamarin.Android 4.6.07004

When we click and hold on the New Class file and Drag it to the New Folder, then
the file dragged under New Folder.

Hence closing this issue.