Bug 27789 - Android: ScrollView is not scrolled, if Entry receives focus, Button-alignment bug (1.4-Pre-2)
Summary: Android: ScrollView is not scrolled, if Entry receives focus, Button-alignmen...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-09 14:30 UTC by Fredy Wenger
Modified: 2016-04-08 18:46 UTC (History)
5 users (show)

Tags: android functionality scrollview entry button ngf
Is this bug a regression?: ---
Last known good build:


Attachments
Details to bug (982.74 KB, application/pdf)
2015-03-09 14:30 UTC, Fredy Wenger
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Fredy Wenger 2015-03-09 14:30:58 UTC
Created attachment 10225 [details]
Details to bug

ScrollView is not scrolled automatically, if an Entry receives focus on Android-tablet (Samsung SM-T900).
Button is aligned left after click (instead of centered) -> "Button evergreen-Bug"
Details, see attachment

Note: Bug 21862 (ScrollView-Bug) has status "VERIFIED FIXED" what is not true (as you can see and comprehend with this bug-description).
Comment 1 Chris King 2015-06-01 17:43:09 UTC
We'd be happy to help you resolve this issue. Please help us by attaching a reduced reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue. If you'd do this for us we would very much appreciate it. If you are able to reproduce the issue without modifying the platform specific projects that would eliminate a number of possibilities and likely expedite a resolution. 

Warm regards,
Xamarin Forms Team
Comment 2 Fredy Wenger 2015-06-02 03:36:19 UTC
@Chris
You have everything you need, including a download-link to the project in the description.
I can't see the button-alignment-bug in the latest version anymore, but the "not-scrolling-bug" still exists (only on the SMM-T900 not on phones).
Since I work with Xamarin (about 8 months), I (really!)have spent more then the halve time (about 4 Months!) to work for Xamarin. Test new versions, search and implement workarounds, create bug-reports (like this), submit my project, try to work with the debugger, help other users, and so on...
So I have done my work for you (much more then I have do - I'm a customer!)
So I don't have the time to try to create a "minimum-app" and rebuild parts of my existing app only to make it a bit easier for you.
Further my app accesses our webservice and data from the webservice also are used on the search-page (what is the page, that causes the problem).
At the end, MY APP has to work (and you have my app already).

So.. please install the project and run it on a SM-T900 (and you can see the problem).
If needed I can send you an actual version of my project once again (but this should not be needed as the bug should be the same).
Fredy
Comment 3 Fredy Wenger 2015-07-06 11:36:33 UTC
As I want to ship my app to the Android shop (iOS already in the shop) I have investigated the bug once again for a full day. 
I have changed all layout-options similar to another page I have (where the autoscroll works) and have done various further tests.
Nothing has worked... :-((
So for me it's a clear bug in the combination of Android + Tablet (maybe only Toshiba SM T900 -> I only have this one) and a "special" layout.  
The bottom line is, that it presumably occurs, if the entry's are the last controls on the page (whereby the autoscroll also not works, if there is further content on the page under the Entry's).  
I have implemented my own workaround now.  
You can find all details under the link below: 

https://forums.xamarin.com/discussion/18125/scrollview-does-not-autoscroll-for-editor-when-keyboard-appears
Comment 4 Rui Marinho 2015-12-16 10:07:57 UTC
Hi Fredy, was trying to look at your sample but it's not available anymore, do you still have this problem?

Thanks

Warm Regards
Xamarin Forms Team
Comment 5 Fredy Wenger 2015-12-16 15:09:18 UTC
Hi Rui
Unfortunately, I can't give you a solid answer.
As the bug was not fixed for a long time, I had to implement a workaround for that myself. The workaround was, to add some "phantom-elements" below the not working autoscroll-element.
Further, I stick on 1.4.4 (not have done the update to 2.x yet).
Greetings from Switzerland
Comment 6 Jason Smith [MSFT] 2016-04-08 18:46:12 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team