Bug 27785 - Android: ViewCell in a ListView is not updated correct (1.4-Pre-2)
Summary: Android: ViewCell in a ListView is not updated correct (1.4-Pre-2)
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-09 13:51 UTC by Fredy Wenger
Modified: 2016-04-08 18:44 UTC (History)
4 users (show)

Tags: android functionality viewcell listview
Is this bug a regression?: ---
Last known good build:


Attachments
Details to bug (622.31 KB, application/pdf)
2015-03-09 13:51 UTC, Fredy Wenger
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Fredy Wenger 2015-03-09 13:51:59 UTC
Created attachment 10224 [details]
Details to bug

Android: If the Data in a List are updated (sorted / re-queried) and the ListView is not on top, the data in the ViewCell are not updated correct.
Details see attachment
This makes the App unusable...
Comment 1 Fredy Wenger 2015-03-31 05:17:22 UTC
Bug still exists in 1.4.1.
Comment 2 Jason Smith [MSFT] 2015-05-27 20:03:29 UTC
We need the following info:

1) How are the stars created?

2) Are they a custom renderer?

3) Can we have the source to this page and the views within it including the custom renderer. Please do not include your entire app, we do not want the entire IP of your project.
Comment 3 Fredy Wenger 2015-05-28 03:33:35 UTC
You have everything you need in the description (including the page that has caused the issue and the ViewCell, where the stars are created).
As I wrote, the Issue don't occurs, if the List is on top, before the action (requery data, sort date) take place.
Therefore, I have implemented (as workaround) to scroll the LV to top in code.
On Android this has not worked in 1.4.1.
As this now also works in Android, my workaround also works Android (where  think (not sure) that the bug still exists (wrong behavior, when the LV is NOT on top).
Comment 4 Jason Smith [MSFT] 2016-04-08 18:44:27 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team