Bug 2774 - HttpRequest.RawUrl property doesn't contain original url if default document is requested
Summary: HttpRequest.RawUrl property doesn't contain original url if default document ...
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web ()
Version: 2.8.x
Hardware: PC All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-08 12:35 UTC by Miloslav
Modified: 2012-01-31 13:22 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Miloslav 2012-01-08 12:35:18 UTC
The default document is specified in web.config file:

<!-- default document -->
<appSettings><add key="MonoServerDefaultIndexFiles"
value="index.php,index.aspx"/></appSettings>

When site URL is requested, RawUrl is changed so the it contains default document.

Requested URL = http://localhost/wordpress
ASP.NET:  Request.RawUrl = http://localhost/wordpress
Mono:     Request.RawUrl = http://localhost/wordpress/index.php
Comment 1 Marek Habersack 2012-01-10 04:07:39 UTC
Fixed in master (commit edb5d4ed06a134cc117e6f2370d60c4023854ac2).
Please test and let me know if it works for you as expected. If it does, I will backport it to 2.11 for inclusion with the next release.
Comment 2 Miloslav 2012-01-31 10:55:15 UTC
Perfect, it works! We can run WordPress 3.3.1 on Mono out of box with this fix. Thank you
Comment 3 Marek Habersack 2012-01-31 13:22:08 UTC
Excellent news :), glad it works!