Bug 27625 - ListView cell with multiple labels height crops content
Summary: ListView cell with multiple labels height crops content
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.5
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-03 22:45 UTC by karl.kopp
Modified: 2015-05-20 17:14 UTC (History)
5 users (show)

Tags: ios visual AC
Is this bug a regression?: ---
Last known good build:


Attachments
Solution for bug (101.18 KB, application/zip)
2015-03-03 22:48 UTC, karl.kopp
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description karl.kopp 2015-03-03 22:45:18 UTC
When setting a label width based on screen size in a listview, the height calculated for the label seems correct, but the content is cropped. It seems the top & bottom padding is added whenever the content is cropped.

Repro:
- Open WorkingWithListview sample attached.
- Open app in iOS simulator and click on UnevenX tab. 
- Except for the first row, all other rows have cropped text as part of the 'To be or not to be' quote.
Comment 1 karl.kopp 2015-03-03 22:48:48 UTC
Created attachment 10141 [details]
Solution for bug
Comment 2 Abhishek 2015-03-05 01:42:25 UTC
I have tried this issue and able to reproduce this issue at my end.

Steps To Reproduce:
1. Download the attached application.
2. Run the application on simulator/Device.
3. Click on UnevenX tab.
4. Tab on second,third row and so on.It will show cropped text.

Screencast: http://www.screencast.com/t/vypBhmBj
IOS Device Log: https://gist.github.com/AkhileshKumar01/b916e9cc1803e966c80f

Environment Info:

Xamarin.Forms 1.4.0.6336-pre1
Xamamrin.Forms 1.3.5.6335

=== Xamarin Studio ===

Version 5.7.2 (build 7)
Installation UUID: 93e693b0-b53d-40f4-b29c-b61ff5cbe892
Runtime:
	Mono 3.12.0 ((detached/b8f5055)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000077

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.Mac ===

Version: 1.12.0.8 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.6.2.26 (Enterprise Edition)
Hash: 9905782
Branch: 
Build date: 2015-02-26 11:05:07-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Enterprise Edition)
Android SDK: /Users/xamarin23/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Build Information ===

Release ID: 507020007
Git revision: dcf3f486177d3e625349b51a8f3be807e3fa7712
Build date: 2015-02-24 09:14:27-05
Xamarin addins: ea7c65bb7876e4a876ab365208e94acdf8f330ef

=== Operating System ===

Mac OS X 10.10.0
Darwin 800BC.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 3 Seth Rosetter 2015-05-20 17:13:37 UTC
I have confirmed your issue. Updating Xamarin Forms 1.4.2 (current stable) seemed to resolve the issue. I'm marking the issue as resolved.

Thanks,
-Seth