Bug 27604 - UmAlQuraaCalendar wrong data!
Summary: UmAlQuraaCalendar wrong data!
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-03-03 12:12 UTC by mostafa
Modified: 2015-03-05 08:55 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description mostafa 2015-03-03 12:12:09 UTC
I looks like the data tables or calculations used in building mono version UmAlQuraCalendar class is faulty, an example i have came by by accident!

Code:

    System.Globalization.UmAlQuraCalendar calender = new System.Globalization.UmAlQuraCalendar();
    int days = calender.GetDaysInMonth(1436, 9);


Executing the above code in a Windows Application using the original Microsoft implementation of the mentioned class 
yields result  (days = 29)
Executing the same code in an Android Application using Mono implementation yields result (days = 30)
Comment 1 mostafa 2015-03-03 12:13:48 UTC
I am using Xamarin's latest versions/updates to date.
Comment 2 Marek Safar 2015-03-05 08:55:17 UTC
Already fixed in Mono 4.0