Bug 27502 - Content of a ViewCell disappears when it's selected in a ListView
Summary: Content of a ViewCell disappears when it's selected in a ListView
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-02-27 09:08 UTC by John Miller [MSFT]
Modified: 2015-07-16 10:15 UTC (History)
9 users (show)

Tags: ios viewcell visual AC
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (174.24 KB, application/zip)
2015-02-27 09:08 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2015-02-27 09:08:44 UTC
Created attachment 10084 [details]
Test Case

**Overview:**

   The attached project demonstrates an issue where the content (BoxView) of a ViewCell disappears when the cell is selected. http://screencast.com/t/O2LMegNTOLR2

**Steps to Reproduce:**

   1. Run the attached project on an iOS simulator
   2. Tap any cell to select it

**Actual Results:**

   http://screencast.com/t/O2LMegNTOLR2

**Expected Results:**

   The red BoxView should still be visible when the item is selected. 

**Build Date & Platform:**

   XF 1.3.4
Comment 1 Naqeeb 2015-03-02 08:50:28 UTC
I have checked this issue with the help of attached Test sample project and able to reproduce successfully. To reproduce this issue I have followed below steps:

1. Open Test Case on XS.
2. Deploy on iOS simulator.
3. Tap any cell.

When we tap any cell the red 'BoxView' get invisible. Same as screencast: http://www.screencast.com/t/VxgnVLzWsg

Ide log: https://gist.github.com/sunil360/dc1583595af39f1e2f17
System log: https://gist.github.com/sunil360/04e095b91d5c08ed0f2c

I have checked this issue both Xamarin.Forms 1.3.4.6332 and Xamarin.Forms 1.3.5.6333-pre1

Environment info:
=== Xamarin Studio ===

Version 5.7.2 (build 8)
Installation UUID: 561c7a69-0a91-4bae-ad7c-f0c79d594337
Runtime:
	Mono 3.12.0 ((detached/b8f5055)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000077

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 8.6.2.26 (Business Edition)
Hash: 9905782
Branch: 
Build date: 2015-02-26 11:05:07-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Trial Edition)
Android SDK: /Users/tajinder/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.18 (Business Edition)

=== Build Information ===

Release ID: 507020008
Git revision: 64a4266f0a82f7558472383d8ae66a526b3b881d
Build date: 2015-02-25 11:22:12-05
Xamarin addins: 1cb443ca2dddd9933d748e035560f06cf9c246bd

=== Operating System ===

Mac OS X 10.8.4
Darwin Tajinders-iMac.local 12.4.2 Darwin Kernel Version 12.4.2
    Mon Jun 17 18:00:12 PDT 2013
    root:xnu-2050.45.8~1/RELEASE_X86_64 x86_64
Comment 2 Stephane Delcroix 2015-06-25 06:06:02 UTC
this will be fixed in 1.4.4
Comment 3 Stephane Delcroix 2015-06-25 06:14:07 UTC
not fixed for all the cases
Comment 4 Rui Marinho 2015-06-25 06:32:35 UTC
Fixed again , now for all cases 1.4.4
Comment 5 Stephane Delcroix 2015-06-26 03:40:48 UTC
happens for other controls than just BoxViews, reopening
Comment 6 Jason Smith [MSFT] 2015-07-01 05:56:46 UTC
This bug was about boxview. The other controls backgrounds are overwritten by iOS because thats how iOS works. If in the future we want to change this we can entertain a feature/configuration option.
Comment 7 Parmendra Kumar 2015-07-16 10:15:47 UTC
I have checked this issue with X.F 1.4.4-pre1 and its working fine at my end.
The red BoxView still be visible when the item is selected.

Screencast: http://www.screencast.com/t/aIfOipG3gby

Hence closing this issue.