Bug 27380 - [XAP] Update Available causes blue screen
Summary: [XAP] Update Available causes blue screen
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Android Player
Classification: Xamarin
Component: Player ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-24 17:29 UTC by Jon Douglas [MSFT]
Modified: 2015-04-27 07:39 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Logs (14.06 KB, application/zip)
2015-02-24 17:29 UTC, Jon Douglas [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Jon Douglas [MSFT] 2015-02-24 17:29:47 UTC
Created attachment 10015 [details]
Logs

*Customer Description
Upon starting Xamarin Android Player, it informs me that “Update available”. Unfortunately every time I am trying to install the update it crashes my system with a blue screen.

*Additional Information
I am running Windows 8.1 Pro

My machine is not part of any company-managed domain.
Comment 1 Will Schaller 2015-02-26 09:57:59 UTC
Hi, am I right to think the crash is happening during the installation process? If so, the installation involves two parts, is it during the installation of VirtualBox or Xamarin Android Player?

This is most likely an issue with VirtualBox installation, which has been known to cause BSODs (https://www.google.co.uk/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=virtualbox+installation+blue+screen+site:forums.virtualbox.org&start=0)

Could the customer try installing the latest VirtualBox from https://www.virtualbox.org/wiki/Downloads separately and see if that still causes a BSOD?