Bug 2735 - SOAP Web Service and SoapHeader
Summary: SOAP Web Service and SoapHeader
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-04 13:10 UTC by Matronix
Modified: 2013-12-05 18:34 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Matronix 2012-01-04 13:10:12 UTC
Trying to create an object for a .NET C# SOAP Web Service and it throws when trying to create the connection to the web service 

localhost.Service proxy = new localhost.Service()

The exception thrown is: 
System.InvalidOperationException has been thrown
Member LicenseInfoValueField not found in class TestProject.localhost.Service

My Reference.cs file has this:
namespace TestProject.localhost {

[System.Web.Services.WebServiceBinding(Name="ServiceSoap",Namespace="http://XYZ/Stuff/")]
   [System.Diagnostics.DebuggerStepThroughAttribute()]
   [System.ComponentModel.DesignerCategoryAttribute("code")]
   public partial class Service : System.Web.Services.Protocols.SoapHttpClientProtocol {

        private LicenseInfo LicenseInfoValueField;
        private ErrorInfo ErrorInfoValueField;
   ...


My Web Service has SoapHeaders and I don't think MonoTouch supports or is having issues with the SoapHeader.

This is an example of my Web Service method:
       [WebMethod(EnableSession = true)]
       [SoapHeader("LicenseInfo", Direction = SoapHeaderDirection.In)]
       [SoapHeader("ErrorInfo", Direction = SoapHeaderDirection.Out)]
       public DataSet GetInfo(Guid repositoryID)
       {
           ...
       }


MonoTouch is failing to connect to a web service with SoapHeaders. How can this be resolved?
Comment 1 Sebastien Pouliot 2012-01-12 09:57:12 UTC
Such bugs are difficult to reproduce. Please provide a self-contained test case that shows the issue and we'll take a look at it. Thanks!
Comment 2 PJ 2013-11-19 17:03:59 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 3 PJ 2013-12-05 18:34:00 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.