Bug 27333 - could not found the Xamain.Mac.dll when I make
Summary: could not found the Xamain.Mac.dll when I make
Status: RESOLVED INVALID
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: Master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-02-23 20:22 UTC by Junil Um
Modified: 2015-03-25 15:49 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Junil Um 2015-02-23 20:22:42 UTC
I cloned the monodevelop repository usage git.
I work the branch is monodevelop-5.7-branch on MacOS.

./configure --profile=mac --select                # I just selected main(1).
make

the error results:
if test -d ".git"; then \
		git submodule update --init --recursive || exit 1; \
	fi
Making all in external
make[2]: *** No rule to make target `/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/i386/full/Xamarin.Mac.dll', needed by `Xamarin.Mac.dll'.  Stop.
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
Comment 1 Chris Hamons 2015-03-25 15:49:41 UTC
You'll need to contact the mono developer team:

http://www.monodevelop.com/help/

as this is outside of the scope of a Xamarin.Mac bug. (maybe you need a newer Xamarin.Mac version installed?)