Bug 27296 - Can't debug Lollipop at all
Summary: Can't debug Lollipop at all
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 4.20.0
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-22 22:50 UTC by Paul
Modified: 2015-06-02 19:41 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Paul 2015-02-22 22:50:32 UTC
Hi, when trying to debug a software on any device running Lollipop, debugger randomly detaches or throws "Debugger was disconnected.." error message. Tried on the devices: Nexus 5, HTC One M7, LG G3.

The log is here, but I stripped private strings from my app. Although it's pretty useless.

Forwarding debugger port 8847
Detecting existing process
[art] Late-enabling -Xcheck:jni
[monodroid-debug] Trying to initialize the debugger with options: --debugger-agent=transport=dt_socket,loglevel=0,address=127.0.0.1:8847,server=y,embedding=1
[libc] WARNING: generic atexit() called from legacy shared library
[Mono] Image addref mscorlib[0xaa621880] -> mscorlib.dll[0xaa51a400]: 1
[Mono] Assembly mscorlib[0xaa621880] added to domain RootDomain, ref_count=1
[Mono] Assembly GooglePlayServicesLib[0xaa6b0b20] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/GooglePlayServicesLib/GooglePlayServicesLib.config'.
[Mono] Assembly SmartThreadPoolAndroid[0xaa6b0f40] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/SmartThreadPoolAndroid/SmartThreadPoolAndroid.config'.
[Mono] Assembly SQLite[0xaa6b0e80] added to domain RootDomain, ref_count=1
[Mono] Assembly Loader loaded assembly from location: '/storage/emulated/0/Android/data/Foxtel.Presto/files/.__override__/SQLite.dll'.
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/SQLite/SQLite.config'.
[Mono] Assembly Xamarin.Android.Support.v13[0xaa6b0ee0] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/Xamarin.Android.Support.v13/Xamarin.Android.Support.v13.config'.
[Mono] Assembly Xamarin.Android.Support.v4[0xaa6b70a0] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/Xamarin.Android.Support.v4/Xamarin.Android.Support.v4.config'.
[Mono] Assembly Xamarin.Android.Support.v7.AppCompat[0xaa6b7100] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/Xamarin.Android.Support.v7.AppCompat/Xamarin.Android.Support.v7.AppCompat.config'.
[Mono] Assembly Xamarin.Android.Support.v7.MediaRouter[0xaa6b7160] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/Xamarin.Android.Support.v7.MediaRouter/Xamarin.Android.Support.v7.MediaRouter.config'.
[Mono] Assembly Xamarin.Insights[0xaa6b7280] added to domain RootDomain, ref_count=1
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mlion-monodroid-4.21-series/49a04b96/source/monodroid/builds/install/mono-armv7/etc/mono/assemblies/Xamarin.Insights/Xamarin.Insights.config'.
[monodroid-gc] GREF GC Threshold: 46800
[Mono] Image addref Mono.Android[0xaa6b71c0] -> Mono.Android.dll[0xaa6bd000]: 1
[Mono] Assembly Mono.Android[0xaa6b71c0] added to domain RootDomain, ref_count=1
[Mono] AOT module 'Mono.Android.dll.so' not found: dlopen failed: library "/data/data/Foxtel.Presto/lib/Mono.Android.dll.so" not found
[Mono] Assembly Ref addref Mono.Android[0xaa6b71c0] -> mscorlib[0xaa621880]: 2
[Mono] Assembly Ref addref GooglePlayServicesLib[0xaa6b0b20] -> mscorlib[0xaa621880]: 4
[Mono] Assembly Ref addref GooglePlayServicesLib[0xaa6b0b20] -> Mono.Android[0xaa6b71c0]: 3
[Mono] Assembly Ref addref Xamarin.Android.Support.v13[0xaa6b0ee0] -> mscorlib[0xaa621880]: 7
[Mono] Assembly Ref addref Xamarin.Android.Support.v13[0xaa6b0ee0] -> Mono.Android[0xaa6b71c0]: 6
[Mono] Assembly Ref addref Xamarin.Android.Support.v4[0xaa6b70a0] -> mscorlib[0xaa621880]: 8
[Mono] Assembly Ref addref Xamarin.Android.Support.v4[0xaa6b70a0] -> Mono.Android[0xaa6b71c0]: 7
[Mono] Assembly Ref addref Xamarin.Android.Support.v7.AppCompat[0xaa6b7100] -> mscorlib[0xaa621880]: 9
[Mono] Assembly Ref addref Xamarin.Android.Support.v7.AppCompat[0xaa6b7100] -> Mono.Android[0xaa6b71c0]: 8
[Mono] Assembly Ref addref Xamarin.Android.Support.v7.MediaRouter[0xaa6b7160] -> mscorlib[0xaa621880]: 10
[Mono] Assembly Ref addref Xamarin.Android.Support.v7.MediaRouter[0xaa6b7160] -> Mono.Android[0xaa6b71c0]: 9
[Mono] Image addref System.Core[0xaa77a520] -> System.Core.dll[0xaa6bfc00]: 1
Loaded assembly: System.Core.dll [External]
[Mono] Assembly System.Core[0xaa77a520] added to domain RootDomain, ref_count=1
[Mono] AOT module 'System.Core.dll.so' not found: dlopen failed: library "/data/data/Foxtel.Presto/lib/System.Core.dll.so" not found
[Mono] Assembly Ref addref Mono.Android[0xaa6b71c0] -> System.Core[0xaa77a520]: 2
[Mono] Assembly Ref addref System.Core[0xaa77a520] -> mscorlib[0xaa621880]: 11
[Mono] DllImport attempting to load: '__Internal'.
[Mono] DllImport loaded library '(null)'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gc_wait_for_bridge_processing'.
[Mono] Probing '_monodroid_gc_wait_for_bridge_processing'.
[Mono] Found as '_monodroid_gc_wait_for_bridge_processing'.
Loaded assembly: MonoDroidConstructors [External]
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_get_identity_hash_code'.
[Mono] Probing '_monodroid_get_identity_hash_code'.
[Mono] Found as '_monodroid_get_identity_hash_code'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gref_log_new'.
[Mono] Probing '_monodroid_gref_log_new'.
[Mono] Found as '_monodroid_gref_log_new'.
[ContextHelper] convertTheme. context->name=Foxtel.Presto themeResourceId=2131165431
[Mono] Image addref System.Xml[0x98d342e0] -> System.Xml.dll[0xaa6c1c00]: 1
[Mono] Assembly System.Xml[0x98d342e0] added to domain RootDomain, ref_count=1
[Mono] Assembly Ref addref System.Xml[0x98d342e0] -> mscorlib[0xaa621880]: 13
[Mono] Image addref System[0x98d343a0] -> System.dll[0xaa6c4000]: 1
[Mono] Assembly System[0x98d343a0] added to domain RootDomain, ref_count=1
[Mono] Assembly Ref addref Presto[0xaa621a00] -> System[0x98d343a0]: 2
[Mono] Assembly Ref addref System[0x98d343a0] -> mscorlib[0xaa621880]: 14
Loaded assembly: System.Xml.dll [External]
Loaded assembly: System.dll [External]
[Mono] Assembly Ref addref SQLite[0xaa6b0e80] -> mscorlib[0xaa621880]: 15
[Mono] Assembly Ref addref SQLite[0xaa6b0e80] -> System[0x98d343a0]: 3
[Mono] Assembly Ref addref SQLite[0xaa6b0e80] -> Mono.Android[0xaa6b71c0]: 11
[Mono] DllImport attempting to load: '/system/lib/libsqlite.so'.
[Mono] DllImport loaded library '/system/lib/libsqlite.so'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_open_v2'.
[Mono] Probing 'sqlite3_open_v2'.
[Mono] Found as 'sqlite3_open_v2'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_busy_timeout'.
[Mono] Probing 'sqlite3_busy_timeout'.
[Mono] Found as 'sqlite3_busy_timeout'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_step'.
[Mono] Probing 'sqlite3_step'.
[Mono] Found as 'sqlite3_step'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_changes'.
[Mono] Probing 'sqlite3_changes'.
[Mono] Found as 'sqlite3_changes'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_prepare_v2'.
[Mono] Probing 'sqlite3_prepare_v2'.
[Mono] Found as 'sqlite3_prepare_v2'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_bind_parameter_index'.
[Mono] Probing 'sqlite3_bind_parameter_index'.
[Mono] Found as 'sqlite3_bind_parameter_index'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_finalize'.
[Mono] Probing 'sqlite3_finalize'.
[Mono] Found as 'sqlite3_finalize'.
[Mono] Assembly Ref addref SQLite[0xaa6b0e80] -> System.Core[0xaa77a520]: 3
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_count'.
[Mono] Probing 'sqlite3_column_count'.
[Mono] Found as 'sqlite3_column_count'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_type'.
[Mono] Probing 'sqlite3_column_type'.
[Mono] Found as 'sqlite3_column_type'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_name16'.
[Mono] Probing 'sqlite3_column_name16'.
[Mono] Found as 'sqlite3_column_name16'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_int'.
[Mono] Probing 'sqlite3_column_int'.
[Mono] Found as 'sqlite3_column_int'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_double'.
[Mono] Probing 'sqlite3_column_double'.
[Mono] Found as 'sqlite3_column_double'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_int64'.
[Mono] Probing 'sqlite3_column_int64'.
[Mono] Found as 'sqlite3_column_int64'.
[Mono] DllImport searching in: '/system/lib/libsqlite.so' ('/system/lib/libsqlite.so').
[Mono] Searching for 'sqlite3_column_text16'.
[Mono] Probing 'sqlite3_column_text16'.
[Mono] Found as 'sqlite3_column_text16'.
[Mono] DllImport attempting to load: '__Internal'.
[Mono] DllImport loaded library '(null)'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for 'monodroid_get_system_property'.
[Mono] Probing 'monodroid_get_system_property'.
[Mono] Found as 'monodroid_get_system_property'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for 'monodroid_free'.
[Mono] Probing 'monodroid_free'.
[Mono] Found as 'monodroid_free'.
purgeCache: Deleted 0 expired files in 288ms 
[Mono] DllImport attempting to load: '/system/lib/liblog.so'.
[Mono] DllImport loaded library '/system/lib/liblog.so'.
[Mono] DllImport searching in: '/system/lib/liblog.so' ('/system/lib/liblog.so').
[Mono] Searching for '__android_log_print'.
[Mono] Probing '__android_log_print'.
[Mono] Found as '__android_log_print'.
purgeCache: Deleted 0 expired files in 288ms 
purgeCache: Removal of expired db records took 5 ms
purgeCache: Removal of expired db records took 5 ms
[Mono] Assembly Ref addref SmartThreadPoolAndroid[0xaa6b0f40] -> mscorlib[0xaa621880]: 16
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gref_log_delete'.
[Mono] Probing '_monodroid_gref_log_delete'.
[Mono] Found as '_monodroid_gref_log_delete'.
[Configs] The framework log level is 1.
[SensorManager] registerListenerImpl() [Sensor: LGE Accelerometer, Rate: 200000, SensorEventListener: android.view.OrientationEventListener$SensorEventListenerImpl@3f9fdc80] byandroid.view.OrientationEventListener.enable():93
[art] JNI RegisterNativeMethods: attempt to register 0 native methods for go.FancyTextView
[LgDataFeature] LgDataFeature() Constructor: none
[LgDataFeature] LgDataFeature() Constructor Done, null



=== Xamarin Studio ===

Version 5.7.1 (build 17)
Installation UUID: a6a75a2e-663d-4f28-9bee-ec7d1889267d
Runtime:
	Microsoft .NET 4.0.30319.34209
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Enterprise Edition)
Android SDK: C:\Users\pnovodon\AppData\Local\Android\android-sdk
	Supported Android versions:
		4.1 (API level 16)
		4.2 (API level 17)
		4.3 (API level 18)
		4.4 (API level 19)
		5.0 (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:51:07-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)
Comment 1 Paul 2015-02-22 22:56:23 UTC
Additional info: it looks like it gets worse when breakpoints are set.
Comment 2 Paul 2015-03-22 20:37:48 UTC
Hello,

Could you please provide some update regarding this? I find it pretty unacceptable considering that Lollipop has been being available for half a year or so. And now it looks like you guys are totally ignoring it.
Comment 3 Jonathan Pryor 2015-06-02 16:46:21 UTC
We are currently unable to reproduce any issues with debugging on Lollipop (with Xamarin.Android 5.1.2). Is it working for you at this time?
Comment 4 Paul 2015-06-02 19:41:57 UTC
I haven't been seeing the issue for a while, so assume it was resolved at some point. Thanks.