Bug 27254 - [Regression] Binding to self no longer works in a ListView
Summary: [Regression] Binding to self no longer works in a ListView
Status: RESOLVED DUPLICATE of bug 26761
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-20 09:42 UTC by John Miller [MSFT]
Modified: 2015-02-26 10:17 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (301.73 KB, application/zip)
2015-02-20 09:42 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26761

Description John Miller [MSFT] 2015-02-20 09:42:23 UTC
Created attachment 9946 [details]
Test Case

**Overview:**

   Setting a binding in a ListView like "{Binding .}" returns the wrong binding as a ListView scrolls. This used to work in version 1.3.1.

**Steps to Reproduce:**

   1. Run the attached sample on an iOS simulator
   2. Tap a row. The alert will show you the corresponding number of the row tapped. 
   3. Scroll down to the bottom of the list. 
   4. Tap a row. 

**Actual Results:**

   At step #4, the alert no longer matches the tapped row. 

**Expected Results:**

   The alert message should match the row number tapped.

**Build Date & Platform:**

   XF 1.3.4 and tested with XF 1.3.5-pre1

**Additional Information:**

   Downgrade the project to version 1.3.1 and it will work as expected.
   Original poster: https://forums.xamarin.com/discussion/comment/104657
Comment 1 Alexandre 2015-02-20 10:41:45 UTC
Actually, it doesn't work with any bind, not just for self. It's a very important BUG, the "importance" should be more then "normal".
Comment 2 pith 2015-02-22 23:30:20 UTC
I believe that this bug is a duplicate of "[iOS] ListView TapGestureRecognizer Issue" https://bugzilla.xamarin.com/show_bug.cgi?id=26761 "
Comment 3 Parmendra Kumar 2015-02-26 10:17:24 UTC

*** This bug has been marked as a duplicate of bug 26761 ***