Bug 27245 - ViewCell Entry lost focus in listview with Grid
Summary: ViewCell Entry lost focus in listview with Grid
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-20 01:26 UTC by Alessandro
Modified: 2016-04-08 19:37 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Ide log (22.24 KB, application/octet-stream)
2015-02-20 09:13 UTC, Alessandro
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Alessandro 2015-02-20 01:26:24 UTC
This is the same problem "fixed" here

https://bugzilla.xamarin.com/show_bug.cgi?id=25948

I've an entry in a viewcell
if I "tap" on a label, the entry.IsVisible = true but It losts focus.
A numeric keyboard should appear but it is a text keyboard.
I attach an example.
Sorry for the size of the zip, but I have no time to clean all the project.
Tap on label "Margherita" or "Capricciosa" to see the problem
Thanks
Comment 1 Ram Chandra 2015-02-20 03:49:11 UTC
This issue has been fixed with Xamarin.Forms : 1.3.5.6333-pre1. Are you getting this issue with Xamarin.Forms package : 1.3.5.6333-pre1 ? 

Could you please update you Xamarin.Forms package to 1.3.5.6333-pre1 and check this behavior again. 

For now I am closing this issue. If you face this issue after updating the Xamarin.Forms package to 1.3.5.6333-pre1. Please feel free to reopen this issue with attached sample application, build version and IDE logs.

You can get build version form here:

Visual Studio => HELP => About Microsoft Visual Studio => Copy Info

You can get IDE logs from here:

Visual Studio => HELP => Zip Xamarin Logs => attach zipped logs
Comment 2 Alessandro 2015-02-20 04:14:22 UTC
yes, the problem is with 1.3.5.6333-pre1.
I've already attached a sample.
I'm using Xamarin studio
Alessandro
Comment 3 Ram Chandra 2015-02-20 08:48:59 UTC
@Alessandro: Thanks for the information.

I am unable to find attached project with this issue. Could you please attached sample project with this issue. You can attached sample project by clicking on "Add an attachment" link. 

Screencast:  http://www.screencast.com/t/atnCcRed7hvv

If you get chance it might also helpful to include your environment info and IDE logs:

You can get build version form here:

Xamarin  Studio =>About Xamarin Studio => Show Details =>Copy Information ( attached the build info to this issue).

You can get IDE logs from here:

Xamarin Studio => HELP => Open log directory  => Ide log (with latest time stamp)
Comment 4 Alessandro 2015-02-20 09:13:01 UTC
Created attachment 9943 [details]
Ide log
Comment 5 Alessandro 2015-02-20 09:26:30 UTC
for the project, this is the link

https://www.dropbox.com/s/bi41el94feysius/Geco.rar?dl=0

If you press "Margherita" label or "Capricciosa" label, you should find the problem
Comment 6 Alessandro 2015-02-20 12:59:31 UTC
I noticed that, after the "tap" on the label (and the Entry is visible), if I change TAB (ex: from Pizze to Gelati and back to Pizze), then the Entry can have the correct focus with correct keyboard and text is full selected
Comment 7 Jason Smith [MSFT] 2015-03-05 06:33:09 UTC
@Alessandro sorry the reproduction seems to be missing, can you please upload it to the bug report so you dont have to keep it in your dropbox forever? :)
Comment 8 Alessandro 2015-03-05 09:11:23 UTC
@Jason, The zip is too big to upload to bugzilla.
This is the link
Alessandro

https://www.dropbox.com/s/bi41el94feysius/Geco.rar?dl=0
Comment 9 Alessandro 2015-03-14 06:51:51 UTC
Hi guys.
Have you some news about this problem?
I've seen that, if I hide the keyboard and reopen it, the entry works well.

I've these messages from "Output application". It semmes a loop:

id.internal.widget.EditableInputConnection@420220b0 tba=android.view.inputmethod.EditorInfo@42022068 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41fd7ec8 tba=android.view.inputmethod.EditorInfo@41fe4198 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41f43620 tba=android.view.inputmethod.EditorInfo@41f41af8 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41fac8a0 tba=android.view.inputmethod.EditorInfo@41f62d08 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41fda930 tba=android.view.inputmethod.EditorInfo@41fda8e8 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41fd0c08 tba=android.view.inputmethod.EditorInfo@41fd0bc0 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@42017d80 tba=android.view.inputmethod.EditorInfo@4201a8c8 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41e5d750 tba=android.view.inputmethod.EditorInfo@41e23ff0 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@42059098 tba=android.view.inputmethod.EditorInfo@42059050 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@42066d80 tba=android.view.inputmethod.EditorInfo@42066d38 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41faf288 tba=android.view.inputmethod.EditorInfo@41faf240 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41ee1738 tba=android.view.inputmethod.EditorInfo@41ee16f0 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41e735d0 tba=android.view.inputmethod.EditorInfo@41e73588 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41fe47c0 tba=android.view.inputmethod.EditorInfo@41fe4778 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41f5ff90 tba=android.view.inputmethod.EditorInfo@41f5ff48 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41d1a128 tba=android.view.inputmethod.EditorInfo@41d1a0e0 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@41faaa18 tba=android.view.inputmethod.EditorInfo@41faa9d0 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@4201af80 tba=android.view.inputmethod.EditorInfo@4201af38 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.android.internal.widget.EditableInputConnection@42057b00 tba=android.view.inputmethod.EditorInfo@42057ab8 controlFlags=#0
[InputMethodManager] START INPUT: xamarin.forms.platform.android.EntryEditText{41f61a98 VFED..CL .F....ID 0,0-97,42} ic=com.andro

Let me know...
Comment 10 Alessandro 2015-03-14 06:54:24 UTC
I think the problem is about Entry inside a Grid inside a Listview...
Comment 11 E.Z. Hart [MSFT] 2016-04-08 19:37:25 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team