Bug 27176 - CameraAppDemo sample preview image blurry
Summary: CameraAppDemo sample preview image blurry
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.20.0
Hardware: PC Mac OS
: Low normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2015-02-18 07:31 UTC by Allie Miller
Modified: 2016-06-16 15:57 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Allie Miller 2015-02-18 07:31:48 UTC
Overview
When taking pictures using the Android camera intent in the Camera App Sample project, the picture preview (where the user can choose to save or discard the picture) that the camera intent shows after the picture was taken is blurry. However, the actual picture that was saved to the file system is not blurry. 

Steps to reproduce
1) Deploy Camera App Demo sample project to Android device running API 19.
2) Take a picture.
3) Preview the picture taken in Step 2.

Expected results
The picture should be clear

Actual results
The picture appears blurry, but seems clear when viewing the picture after it is saved

Additional information
Original reporter of issue experienced this issue on Samsung Galaxy Note Pro, Note 10.1, Galaxy Tab Active and Galaxy Tab 2 10.1 (all running API 19)

Versioning information
Xamarin.Android 4.20.0.34
Comment 1 Nischal 2015-02-20 01:28:25 UTC
I have checked this issue with following steps given in Comment(0) and observed that When we take picture via Camera App Demo, picture appears blurry and seems clear after saving it.

I have checked it on following devices :
1. Samsung Galaxy Tab S (4.4.2)
2. Samsung Galaxy Tab 4 (4.4.2)

Adb logs:
 Samsung Galaxy Tab S (4.4.2) - https://gist.githubusercontent.com/Shruti360/5f7461dd211018cd93a0/raw/gistfile1.txt
 Samsung Galaxy Tab 4 (4.4.2) - https://gist.githubusercontent.com/Shruti360/35301dd4b9604d30b1f6/raw/gistfile1.txt


Environment Info :
Xamarin Studio
Version 5.8 (build 937)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 3.12.0 ((detached/de2f33f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000076

Apple Developer Tools
Xcode 6.2 (6758)
Build 6C107a

Xamarin.iOS
Version: 8.7.2.30 (Starter Edition)
Hash: 8c7085e
Branch: 
Build date: 2015-02-11 17:34:57-0500

Xamarin.Android
Version: 4.20.0.28 (Starter Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

Xamarin Android Player
Version: Unknown version
Location: /Applications/Xamarin Android Player.app

Xamarin.Mac
Version: 1.12.0.4 (Starter Edition)
Comment 2 narayanp 2016-06-16 15:57:00 UTC
I have checked this issue by following the steps in comment(0) with and observed that this issue is not reproducible.

I have checked this on following devices:
1). Nexus 5 (API 23)
2). Nexus 4 (API 19)
3). Samsung Galaxy Tab 4 (API 21)
4). Samsung Galaxy S 3 Mini (API 16)
5). Motorola G3 (API 23)  

Now, This issue is working fine hence closing this issue.

Environment Info:
Gist:https://gist.github.com/abhisheks360/556023c6d27f2226ed45198c1b1ba7c7