Bug 27166 - Getting "Cannot copy file as the source file doesn't" error
Summary: Getting "Cannot copy file as the source file doesn't" error
Status: RESOLVED DUPLICATE of bug 26606
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.9
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-17 18:52 UTC by Yegor Ius
Modified: 2015-03-04 16:20 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Source file doesnt exist errors (36.91 KB, text/plain)
2015-02-17 18:53 UTC, Yegor Ius
Details
Visual Studio and Xamarin.iOS version (3.14 KB, application/octet-stream)
2015-02-17 18:53 UTC, Yegor Ius
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26606

Description Yegor Ius 2015-02-17 18:52:53 UTC
Hi,

We're getting lots of "Cannot copy <file> as the source file doesn't" errors when trying to build from VS to Xamarin Build Host. Build in XS works, but cannot deploy from VS (actually, it takes several builds to deploy from VS, very annoying).
Error logs and VS info are attached.

We're seeing that this similar bug has been marked as resolved: https://bugzilla.xamarin.com/show_bug.cgi?id=26606
Is migrating to Unified API the only solution?

Thanks.
Comment 1 Yegor Ius 2015-02-17 18:53:30 UTC
Created attachment 9892 [details]
Source file doesnt exist errors
Comment 2 Yegor Ius 2015-02-17 18:53:46 UTC
Created attachment 9893 [details]
Visual Studio and Xamarin.iOS version
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2015-03-04 16:20:45 UTC
The version information from comment 2 shows XamarinVS version 3.9.289 (39a70ae), which _has the bug_ (as noted in bug 26606, comment 0), so I'm going to mark this bug as a duplicate of bug 26606.


XamarinVS 3.9.344 includes the fix for bug 26606, so version 3.9.344 will stop the problem in many cases. But as a caution, note that there is still one particular scenario where this error will still occur in 3.9.344: when the assembly name for the class library does not match the project name. I have filed a new bug for that second problem here: Bug 27665.


If neither bug 26606 nor bug 27665 matches the problem in your particular case, feel free to reply on this bug report (bug 27166), or feel free to send us an email via contact@xamarin.com to let us know.


Thanks!
Brendan
Xamarin Customer Support

*** This bug has been marked as a duplicate of bug 26606 ***