Bug 27078 - Error During Build: Circular base class dependency involving 'Class' and 'Class'
Summary: Error During Build: Circular base class dependency involving 'Class' and 'Class'
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms ()
Version: 4.0.0 (C6)
Hardware: PC All
: Normal normal
Target Milestone: ---
Assignee: Udham Singh
URL:
Depends on:
Blocks:
 
Reported: 2015-02-15 17:41 UTC by Michael
Modified: 2016-12-23 12:49 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Zip Xamarin Logs (2.37 KB, application/octet-stream)
2015-02-16 03:37 UTC, Udham Singh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Michael 2015-02-15 17:41:35 UTC
I am pretty sure this has to do with Xamarin.Forms.targets.  Please look at the following project:
https://github.com/Michael-DST/Stash/tree/master/XamarinFormsBuild

And try to build it.  You will see 1 project that builds as expected (WPF), but the other one (Xamarin.Forms PCL) does not.  Seems like the full name of the class is not being used somewhere during the build, causing the error.

Please let me know if you have any questions around this.
Comment 1 Udham Singh 2015-02-16 03:37:49 UTC
Created attachment 9844 [details]
Zip Xamarin Logs

I have checked this issue with the help of sample app given in bug description and able to reproduce the reported behaviour. Please refer the screencast : http://www.screencast.com/t/btytlUNW84

Environment Info : 

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Xamarin   3.9.325.0 (96e7814)
Comment 2 Udham Singh 2015-02-16 03:39:06 UTC
An update to the above comment : I have checked this issue with Xamarin.Forms.1.3.4.6331-pre4
Comment 3 mag@xamarin.com 2016-12-23 12:49:09 UTC
We have made several improvements on Xamarin Forms, so given that this issue has been reported long time ago, I mark this as Resolved.
Please feel free to re open it if you still experience issues related to this report.