Bug 26977 - Listview with HasUnevenRows doesn't properly refreshes the list when scrolling
Summary: Listview with HasUnevenRows doesn't properly refreshes the list when scrolling
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-11 18:29 UTC by cdetera@computronsoftware.com
Modified: 2015-02-25 12:55 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Project to Replicate the Issue (4.35 MB, application/x-zip-compressed)
2015-02-11 18:29 UTC, cdetera@computronsoftware.com
Details
Xmarin Studio Info (1.71 KB, application/msword)
2015-02-11 18:30 UTC, cdetera@computronsoftware.com
Details
Screen Recording Showing the Issue (4.30 MB, video/quicktime)
2015-02-11 18:31 UTC, cdetera@computronsoftware.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description cdetera@computronsoftware.com 2015-02-11 18:29:15 UTC
Created attachment 9782 [details]
Project to Replicate the Issue

I have a Xamarin.Forms app that uses a ListView with an HasUnevenRows = true.  The ItemTemplate of the ListView is implemented with a Dynamic View Cell where the Cell Height gets set OnBindingContextChanged.

As I scroll down through the viable sized list items the description text is missing on some of them (all rows have a description).

Scrolling up and down the list those that previously have description get their descriptions cleared as well.

As I scroll up and down the list the descriptions disappears on others, and so on.

I created a small project that has all the elements of my app and was able to replicate the same issue.  Please see the attached project.  ListView code is in the Views/NamedColorsPage.cs in the Portable project.  Note that I am running on the latest Stable version of Xamarin.Forms 1.3.3.

Also note that this works fine in Adndroid and the issue is happening in iOS (both Retina 8.1 Simulator and actual device).

I have attached a video (screen movie of the simulator) to show the issue with the attached project.  Also, attached is my XS info.
Comment 1 cdetera@computronsoftware.com 2015-02-11 18:30:48 UTC
Created attachment 9783 [details]
Xmarin Studio Info
Comment 2 cdetera@computronsoftware.com 2015-02-11 18:31:25 UTC
Created attachment 9784 [details]
Screen Recording Showing the Issue
Comment 3 cdetera@computronsoftware.com 2015-02-12 10:22:25 UTC
Please note too that this works great before the 1.3.1 update.
Comment 4 Naqeeb 2015-02-12 11:14:52 UTC
I checked this issue and I am able to reproduce this issue with Xamarin.Forms 1.3.3.6323 but after updating Xamarin.Forms 1.3.4.6329-pre3 and observed that it is working fine.

Please reopen it again if you are able to reproduce this issue with updated Xamarin.Forms 1.3.4.6329-pre3.

Screencast: http://www.screencast.com/t/PG2AXBai1y

Environment info:
=== Xamarin Studio ===

Version 5.7.1 (build 17)
Installation UUID: ff0c16c6-3c75-46d8-ac56-56c3b56e2c76
Runtime:
	Mono 3.12.0 ((detached/de2f33f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000076

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.1.20 (Trial Edition)
Hash: 3b3ef43
Branch: 
Build date: 2015-01-24 09:42:21-0500

=== Xamarin.Mac ===

Version: 1.12.0.6 (Indie Edition)

=== Xamarin.Android ===

Version: 4.20.0.28 (Trial Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Build Information ===

Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:43:29-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Mac OS X 10.10.1
Darwin Apples-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 5 cdetera@computronsoftware.com 2015-02-12 11:17:34 UTC
Can you tell me when the Xamarin.Forms 1.3.4.6329-pre3 is going to be released in the Stable channel or at least this be included in a Stable channel release?  Thanks
Comment 6 Naqeeb 2015-02-12 12:48:02 UTC
You will get the fixed patch very soon. Hopefully next week.

Thanks!
Comment 7 cdetera@computronsoftware.com 2015-02-12 14:10:38 UTC
Thanks much!
Comment 8 Parmendra Kumar 2015-02-25 12:55:01 UTC
I have checked this issue with Xamarin.forms version 1.3.4.6332 and now its working fine at my end.

Hence closing this issue.