Bug 26937 - xbuild WriteLinesToFile task does not write a semicolon when provided with escaped special character %3B
Summary: xbuild WriteLinesToFile task does not write a semicolon when provided with es...
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-10 18:44 UTC by Kyle Estes
Modified: 2018-03-15 10:40 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Kyle Estes 2015-02-10 18:44:18 UTC
The WriteLinesToFile task in particular seems to fail to write escaped semicolons in particular.
  - The WriteLinesToFile task writes other special characters, such as an asterisk, correctly
  - The Message task writes semicolons correctly to the console

Here is an example file, Build.proj:

<?xml version="1.0" encoding="utf-8"?>
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003" DefaultTargets="Default">
  <Target Name="Default">
    <PropertyGroup>
      <Lines>This line should end with an asterisk and a semicolon%2A%3B</Lines>
    </PropertyGroup>
    <WriteLinesToFile File="Bug.txt" Lines="$(Lines)"/>
    <Message Text="$(Lines)"/>
  </Target>
</Project>

When I invoke xbuild on Build.proj, I expect the following output on the console and in Bug.txt:
  - Console: This line should end with an asterisk and a semicolon*;
  - Bug.txt: This line should end with an asterisk and a semicolon*;

However, I get the following actual output on the console and in Bug.txt (note the missing semicolon in Bug.txt):
  - Console: This line should end with an asterisk and a semicolon*;
  - Bug.txt: This line should end with an asterisk and a semicolon*
Comment 1 Kyle Estes 2015-02-10 18:47:50 UTC
Kyles-MacBook-Pro:~ kyleestes$ xbuild Bug.proj 
XBuild Engine Version 12.0
Mono, Version 3.12.0.0
Copyright (C) 2005-2013 Various Mono authors

Build started 2/10/2015 5:38:43 PM.
__________________________________________________
Project "/Users/kyleestes/Bug.proj" (default target(s)):
	Target Default:
		This line should end with an asterisk and a semicolon*;
Done building project "/Users/kyleestes/Bug.proj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:00.0642030
Comment 2 Nate Cook 2017-02-14 23:57:37 UTC
This bug still exists
Comment 3 Marek Safar 2018-03-15 10:40:07 UTC
We deprecated xbuild and recommend using msbuild instead. Switching to msbuild will also most likely resolve the issue you reported.