Bug 26913 - Cannot deploy to iPad when project references a project that contains images since Xamarin.iOS 8.6.1.0
Summary: Cannot deploy to iPad when project references a project that contains images ...
Status: RESOLVED DUPLICATE of bug 26606
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.9
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-10 11:24 UTC by Alexandre Pepin
Modified: 2015-02-12 19:19 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project (6.57 MB, application/zip)
2015-02-10 11:24 UTC, Alexandre Pepin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26606

Description Alexandre Pepin 2015-02-10 11:24:16 UTC
Created attachment 9752 [details]
Sample project

I get the error

Cannot copy /Users/alexandre.pepin/Library/Caches/Xamarin/mtbs/builds/44a29c9778e0cd16a0e52f41c9c78c4a/Images/Xamarin.png to /Users/alexandre.pepin/Library/Caches/Xamarin/mtbs/builds/iPadTest/b6429dcc8812e8a99949ec5ebfcea14c/bin/iPhone/Debug/iPadTest.app/Images/Xamarin.png, as the source file doesn't exist.
Xamarin.png is an image that my referenced project used. Please see the attached sample.

Deploying on the simulator works.
Deploying on device with xamarin studio works
Rebuilding, cleaning and restarting visual studio doesn't work

Please help because I can no longer deploy my app

Installed versions :

Microsoft Visual Studio Premium 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Premium

Xamarin 3.9.289.0 (39a70ae)
Xamarin.Android 4.20.0.34 (49a04b966feb40dfdba49d57ba16249b66d606a6)
Xamarin.iOS 8.6.1.0 (3b3ef438017c7ecf486defa9e01567a5f2b3cb2a)
Xamarin.iOS Unified Migration 1.0

Forum thread : http://forums.xamarin.com/discussion/32626/cannot-deploy-to-ipad-when-project-references-a-project-that-contains-images-since-xamarin-ios-8-6-1?new=1
Comment 1 Kent Green [MSFT] 2015-02-12 19:19:41 UTC
This bug is a duplicate of Bug 26606 - [XVS.iOS 3.9] XIB files within iOS Class Libraries cause "Cannot copy ... /builds/$(BuildSessionId)/obj/ ... .nib ... as the source file doesn't exist"

Based on mine and Brendan's tests with the sample provided, we were able to confirm that like bug 26606, the issue is seen when using the Classic API, but does not occur in the Unified API; as once the sample was migrated the bug stopped occurring.

*** This bug has been marked as a duplicate of bug 26606 ***