Bug 26911 - Profiler not included in Xam.Mac app
Summary: Profiler not included in Xam.Mac app
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: Master
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-02-10 11:22 UTC by Rodrigo Moya
Modified: 2015-02-12 13:11 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rodrigo Moya 2015-02-10 11:22:11 UTC
I am trying to profile a Xam.Mac app with the runtime profiler (:D) with:

$ MONO_ENV_OPTIONS=--profile=log:sample bin/Debug/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

and getting:

Unsupported command line option: '--profile=log:sample’

which looks like the profiler log module is not included in the .app bundle.
Comment 1 Udham Singh 2015-02-10 11:54:49 UTC
I have tried to reproduce this issue but not able to reproduce this. To reproduce this issue I have created a Xamarin.Mac project and go to menu run but I did not get option 'Start Profiling' to start profiler.

Screencast : http://www.screencast.com/t/j8OzPpFLb0

Could you please provide some steps/suggestion? So that I can reproduce this issue at my end.

Thanks!

Environment Info :

XamarinProfiler.Mac 0.10-750 (1)

=== Xamarin Studio ===

Version 5.7.1 (build 17)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.2 (6770)
Build 6C121

=== Xamarin.Mac ===

Version: 1.12.0.4 (Business Edition)

=== Build Information ===

Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:43:29-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin76s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-02-10 12:02:33 UTC
I know what the problem is.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-02-12 13:11:30 UTC
Fixed.

maccore/master: 22a96f80684cf62c7f425967aa49124be43c3323