Bug 2680 - Proxy autodetection on Mac doesn't work
Summary: Proxy autodetection on Mac doesn't work
Status: RESOLVED DUPLICATE of bug 1606
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- major
Target Milestone: Untriaged
Assignee: Jeffrey Stedfast
URL:
: 1901 ()
Depends on:
Blocks:
 
Reported: 2011-12-28 21:14 UTC by Mikayla Hutchinson [MSFT]
Modified: 2012-06-01 12:37 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 1606

Description Mikayla Hutchinson [MSFT] 2011-12-28 21:14:02 UTC
Proxy autodetection on Mac was implemented but doesn't work because it relies on finding MonoMac.dll, which is not in the GAC and is unlikely to be directly in an app's directory.
Comment 1 Mikayla Hutchinson [MSFT] 2012-02-06 13:11:05 UTC
*** Bug 1901 has been marked as a duplicate of this bug. ***
Comment 2 Chris Hardy [MSFT] 2012-02-10 14:44:32 UTC
We're having more customers hit this issue causing the auto-updater not to function at all and the latest news on the MonoDevelop homepage not to show up.
Comment 3 Chris Hardy [MSFT] 2012-02-10 15:07:10 UTC
Bumping to a "Major" issue since we heavily rely on the auto-updater to be able to connect to the internet.
Comment 4 René Ruppert 2012-03-02 13:29:44 UTC
I cannot use Monodevelop with our company's source control. I think this is really high prio to fix.
What about this MonoMac.dll being in the App Folder? Is that a workaround?
Comment 5 Chris Hardy [MSFT] 2012-06-01 07:20:00 UTC
Is this the same issue: https://bugzilla.xamarin.com/show_bug.cgi?id=1606 ?
Comment 6 Jeffrey Stedfast 2012-06-01 12:37:31 UTC
Ah, yes, this has been implemented.

*** This bug has been marked as a duplicate of bug 1606 ***