Bug 26799 - Error text in Errors pad is sometimes broken
Summary: Error text in Errors pad is sometimes broken
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 5.1
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2015-02-06 03:55 UTC by domen
Modified: 2016-08-27 18:59 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Errors pad with the bug (24.11 KB, image/png)
2015-02-06 03:56 UTC, domen
Details
Errors pad with the bug (25.46 KB, image/png)
2015-02-06 03:57 UTC, domen
Details
Build output (the second Errors pad image) (1.42 KB, text/plain)
2015-02-06 03:57 UTC, domen
Details
Test project to reproduce the issue (13.33 KB, application/x-zip-compressed)
2015-04-17 09:38 UTC, domen
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 26799 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description domen 2015-02-06 03:55:37 UTC
Sometimes error text in Errors pad in Xamarin Studio is broken. It looks like random substring are merged. Please see attached images. For the second image I have also copied part of the build output that I thought it would be relevant.

Bug is hard to reproduce.


My Xamarin version data:

Xamarin Studio
Version 5.7 (build 661)
Installation UUID: 59a6b98a-f16f-4f0a-9aa9-e5192209be89
Runtime:
    Microsoft .NET 4.0.30319.34209
    GTK+ 2.24.22 (MS-Windows theme)
    GTK# 2.12.26

Xamarin.Android
Version: 4.20.0 (Indie Edition)
Android SDK: [...]
    Supported Android versions:
        4.0.3 (API level 15)
        4.1   (API level 16)
        4.4   (API level 19)
        5.0   (API level 21)
Java SDK: [...]
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

Build Information
Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 11:27:37-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7
Comment 1 domen 2015-02-06 03:56:51 UTC
Created attachment 9678 [details]
Errors pad with the bug
Comment 2 domen 2015-02-06 03:57:04 UTC
Created attachment 9679 [details]
Errors pad with the bug
Comment 3 domen 2015-02-06 03:57:44 UTC
Created attachment 9680 [details]
Build output (the second Errors pad image)
Comment 4 Mikayla Hutchinson [MSFT] 2015-02-06 13:09:21 UTC
It looks like the Android build tasks are not using the correct encoding reading from the tools they invoke.
Comment 5 Tajinder Singh 2015-04-03 10:02:23 UTC
I have checked this issue and unable to reproduce this issue by given description with build XS 5.7 (build 661).

Steps to Reproduce:
1. Open XS.
2. Create Android Java Bindings Library project from File> New Solution.
3. Build the project.
4. Open Errors pad from View menu.

Please refer to screencast: http://www.screencast.com/t/somL3lkrYdS2 
Ide Log: https://gist.github.com/saurabh360/89df25e483549259255a

Please let us know if there is any additional information that would be helpful to reproduce this issue.

Also could you please attach the logs  and screen cast from following place:


Environment Info:
=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: 0fb5291e-76e3-4284-a0c6-c4bb780ba6c2
Runtime:
	Microsoft .NET 4.0.30319.0
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Indie Edition)
Android SDK: D:\android-sdk
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_67
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 11:27:37-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 6 domen 2015-04-17 09:38:52 UTC
Created attachment 10799 [details]
Test project to reproduce the issue
Comment 7 domen 2015-04-17 09:44:50 UTC
I've created test project to reproduce the issue. This bug happens only when PNG files have unrecognised colour profile attached.

Steps to reproduce:
* Open project Layout.
* Rebuild project (CTRL+F8).
* Check Errors pad. There should be three warnings about unrecognised colour profile. If everything seems fine, rebuild project again. Try a few times (bug almost always appears after five rebuilds).

Sometimes text is randomly merged (see images) or some warnings are duplicated/missing (there should be three warning about colour profiles, but sometimes there are two, five or six).
Comment 8 Tajinder Singh 2015-04-23 01:37:29 UTC
I have checked this issue and able to reproduce this issue with the help of bug description and attached sample.

screen cast: http://www.screencast.com/t/xGEevODc
Ide logs: https://gist.github.com/saurabh360/c5c193f42abead5220a0

Environment Info:
=== Xamarin Studio ===

Version 5.9 (build 434)
Installation UUID: 0fb5291e-76e3-4284-a0c6-c4bb780ba6c2
Runtime:
	Microsoft .NET 4.0.30319.0
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 5.1.0 (Starter Edition)
Android SDK: D:\android-sdk
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_67
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.4
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

=== Build Information ===

Release ID: 509000434
Git revision: 1291dafc0e3477de3999eb2019517f7dc181e443
Build date: 2015-04-22 16:25:32-04
Xamarin addins: 21fd95f743742c5237e22023996c2800ce3f8db3

=== Operating System ===

Windows 6.2.9200.0 (64-bit)