Bug 26671 - Xamarin Forms app Crashes on 3GS IOS 6.1.3 when we use webview in MainPage
Summary: Xamarin Forms app Crashes on 3GS IOS 6.1.3 when we use webview in MainPage
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Mac OS
: Highest normal
Target Milestone: ---
Assignee: Jason Smith [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-02-02 23:56 UTC by Prashant Cholachagudda
Modified: 2016-04-08 19:08 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Prashant Cholachagudda 2015-02-02 23:56:31 UTC
Xamarin Forms(Unified API) app Crashes on 3GS IOS 6.1.3 when we use webview in MainPage

The following code in the app crashes:

MainPage = new ContentPage(){Content = new StackLayout() { Children = { new
Xamarin.Forms.WebView(){Source = new UrlWebViewSource(){Url = "
http://google.com"}}}}};

However,
This does not crash:
MainPage = new ContentPage(){Content = new StackLayout() { Children = { new
Button() {Text = "Test"}}}};

Crash log: https://gist.github.com/prashantvc/03ac8d9daf4fb53a13c6
Comment 2 Jason Smith [MSFT] 2015-05-15 15:31:10 UTC
No longer able to reproduce with latest X.iOS. Can you confirm this still happens with latest -pre?
Comment 3 Samantha Houts [MSFT] 2016-04-08 19:08:19 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team