Bug 26654 - Can't create "Blank App (Xamarin.Forms Portable)" project.
Summary: Can't create "Blank App (Xamarin.Forms Portable)" project.
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-02 15:07 UTC by mark.faucher
Modified: 2015-02-09 07:10 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description mark.faucher 2015-02-02 15:07:41 UTC
mattward asked me to submit this.
see http://forums.xamarin.com/discussion/comment/100852#Comment_100852

Windows 7 Professional, Service Pack 1 64 bit
VS 2013 Premium Version 12.0.31101.00 Update 4
NuGet Package Manager 2.8.50926.663

This came up during my Xamarin University XAM120 (Xamarin Forms) class.

I go to New project -> mobile apps -> Blank App (Xamarin.Forms Portable)

Get the following error:

Package Installation Error

Could not add all required packages to the project. The following packages failed to install from 'C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 12.0\COMMON7\IDE\EXTENSIONS\XAMARIN\XAMARIN\3.9.236.0\Packages':`

`Xamarin.Forms.1.3.1.6296 : Could not install package 'Xamarin.Forms 1.3.1.6296'. You are trying to install this package into a project that targets 'portable-net45+win+wpa81+MonoAndroid10+xamarinios10+MonoTouch10', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

I see references to this type of error and it talks about VS2013 not being at least update 2 (I’m on update 4), or Nuget Package Manager needing to be 2.8.3 or higher (I’m on 2.8.50926.663). This seems to show the same error: here.

Note: I can run Phoneword (in Xamarin Android Player) contained in the class materials (Part 03 Resources/Phoneword.Completed). I just can't seem to create the "Blank App (Xamarin.Forms Portable)" project.

Also, the instructor (Andrian Stevens) asked if I could create a "Class Library (Portable)" project and then add Xamarin.Forms via Nuget after. I get the same error. And Adrian confirmed that he also gets the same error when attempting to manually add Xamarin.Forms to the project via "manage nuget packages".
Comment 1 Jatin 2015-02-03 02:52:46 UTC
I am not able to reproduce this issue at my end using the stable build (XVS 3.9.236) as well as XVS 3.9.239 and XVS 3.9.289

I have tried on Windows 7 32 bit as well as Windows 7 64 bit

Also the version of the following at my end:
VS 2013 Premium Version 12.0.31101.00 Update 4
NuGet Package Manager 2.8.50926.663

And the Xamarin.Forms.1.3.1.6296 are getting installed successfully at my end.

Below is the screencast for the same:
http://www.screencast.com/t/lVd0s30j60

Build information:
=== Xamarin Studio ===

Version 5.7.1 (build 15)
Installation UUID: 9964a087-9af9-4da0-aa20-07ca4b85f306
Runtime:
 Microsoft .NET 4.0.30319.18408
 GTK+ 2.24.22 (MS-Windows theme)
 GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Business Edition)
Android SDK: D:\android-sdk
 Supported Android versions:
  2.1    (API level 7)
  2.2    (API level 8)
  2.3    (API level 10)
  3.1    (API level 12)
  4.0.3  (API level 15)
  4.4    (API level 19)
  4.4.87 (API level 20)
  5.0    (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 507010015
Git revision: ce24e991948c7f3d88b0194a14fc1996d848ef51
Build date: 2015-01-26 14:31:20-05
Xamarin addins: 6895e3222bfa6910524708aa0633ff3db99bc3a0

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)

Note: Please check again using the latest stable build or the Alpha build, i.e. 3.9.289 and let me know if you are still facing the issue.

Also, if you still face the issue please provide us with some more information, i.e.

1. Video demonstrating the issue
2. Build information (Copying from XS >> Help >> About >> Show information >> Copy) in order to get us know the version of Java you are using (ideally it should be java 1.7)
Comment 2 Matt Ward 2015-02-09 07:10:19 UTC
Reading the forum post it seems to be a problem with the PCL profiles that Visual Studio installs on Windows. The following knowledge base article has information on how to resolved the problem:

http://kb.xamarin.com/customer/portal/articles/1825426-you-are-trying-to-install-this-package-into-a-project-that-targets-wpa81