Bug 26617 - Android.Graphics.Color.Green isn't really green
Summary: Android.Graphics.Color.Green isn't really green
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 5.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: 5.1
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-02-01 18:34 UTC by Cody Beyer (MSFT)
Modified: 2015-05-05 06:35 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Cody Beyer (MSFT) 2015-02-01 18:34:28 UTC
### Description 

The value for Android.Graphics.Color.Green is 0,128,0 instead of 0,255,0

### Test Case

https://www.dropbox.com/s/vgdhwic2ll21v2g/121723Color.zip?dl=0

### Screenshot

https://www.dropbox.com/s/htdqzydk5aax4ka/Screenshot%202015-02-01%2015.17.13.png?dl=0

### Steps to reproduce

1. Open attached test case
2. Deploy to Android Emulator
3. Click button

### Expected Behavior 

The button text should be pure green with a text demonstrating that 0,255,0

### Actual Behavior

The button text is pretty green, with text demonstrating 0,128,0

### Version

=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: 05ebd865-76e1-4bc2-84a5-7bba54e97af1
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.0.51 (Business Edition)
Hash: dfb682f
Branch: 
Build date: 2015-01-08 13:39:32-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.10.2
Darwin Codys-MBP.router 14.1.0 Darwin Kernel Version 14.1.0
    Mon Dec 22 23:10:38 PST 2014
    root:xnu-2782.10.72~2/RELEASE_X86_64 x86_64
Comment 1 Prashant manu 2015-02-02 02:42:48 UTC
We are getting same behavior, as clicking on button show text demonstrating 0,128,0 with pretty green.
Screencast:  http://www.screencast.com/t/Kh1Lm7T1RzTT

Supplement Info:
IDE Log: https://gist.github.com/saurabh360/34d6d4300d619f14d9be
Application output:  https://gist.github.com/saurabh360/657d1864a46bf17a5ebe

Environment Info:
Xamarin Studio
Version 5.7.1 (build 14)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

Xamarin.Android
Version: 4.20.0.28 (Trial Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Apple Developer Tools
Xcode 6.1.1 (6611)
Build 6A2008a

Xamarin.iOS
Version: 8.6.1.20 (Business Edition)
Hash: 3b3ef43
Branch: 
Build date: 2015-01-24 09:42:21-0500

Xamarin.Mac
Version: 1.12.0.4 (Business Edition)

Build Information
Release ID: 507010014
Git revision: a4dd61ad7f8b3695be4b17bcb5c3ae6b81438cf7
Build date: 2015-01-19 15:21:09-05
Xamarin addins: 081208fe3bbf40e24a562867c6c7fba20a9b94b6

Operating System
Mac OS X 10.10.2
Darwin Admin-Macs-Mac-mini.local 14.1.0 Darwin Kernel Version 14.1.0
    Thu Nov 13 18:36:56 PST 2014
    root:xnu-2782.10.65~2/RELEASE_X86_64 x86_64
Comment 2 Jonathan Pryor 2015-02-02 12:25:20 UTC
Fixed in mondroid/29281b18.
Comment 3 Parmendra Kumar 2015-05-05 06:35:22 UTC
I have checked this issue and now its working fine at my end.

Hence closing this issue.

Environment info:

Xamarin Studio 5.9 (build 457)
Xcode 6.2 (6776)
Xamarin.Android : 5.1.0.77 (Enterprise Edition)
Operating System Mac OS X 10.9.4