Bug 26566 - Map with IsShowingUser set to true still polls for location after map is no longer displayed (Android)
Summary: Map with IsShowingUser set to true still polls for location after map is no l...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 1.3.5
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-29 14:26 UTC by Jon Goldberger [MSFT]
Modified: 2015-02-18 10:26 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Project (197.11 KB, application/zip)
2015-01-29 14:26 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jon Goldberger [MSFT] 2015-01-29 14:26:04 UTC
Created attachment 9562 [details]
Test Project

## Description

ON Android, after leaving a ContentPage with a map, where IsShwoingUSer is set to true, the app still polls for location even after the map is no longer being displayed.


## Steps to reproduce

1. Open test project and restore packages.
2. Open AndroidManifest.xml and enter your GoogleMapsAPI key in place of "YourApiKey"
3. Do whatever setting you need in Google's API console to get maps to show. (Add app to your "Key for Android Apps" in the APIs and Auth->Credentials page)
4. Launch the Android application.
5. Click on the button to open the map.
6. Note that location is polling.
7. Press the back button to exit the map

Expected result: Location polling will stop

Actual result: Location polling continues. 


## Note

The workaround would be to override OnDisappearing() for the page that displays the map and set IsShowingUser to false in that method.
Comment 2 Jon Goldberger [MSFT] 2015-01-29 14:29:01 UTC
Additional Note:

I tested this with Forms 1.3.1.6296 and 1.3.2.6309-pre2
Comment 3 Ram Chandra 2015-02-03 10:38:43 UTC
I have checked this issue and with the help of attached project I am able to reproduce this issue.

I observed that when I come back form map page where IsShowingUser property is true the  app shows the Location polling when I exit from map page.

Screencast: http://www.screencast.com/t/dGGWdz01Y6st

Application Output: https://gist.github.com/saurabh360/a394e7305b31ec977441
IDE Logs: https://gist.github.com/saurabh360/72f052ad13bc30425abd
Device Logs: https://gist.github.com/saurabh360/5ceccd51ec2add23e6ea

Environment Info:

Xamarin.Forms: 1.3.3.6318-pre1

=== Xamarin Studio ===

Version 5.7.1 (build 16)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.6.1.20 (Business Edition)
Hash: 3b3ef43
Branch: 
Build date: 2015-01-24 09:42:21-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.12.0.4 (Business Edition)

=== Build Information ===

Release ID: 507010016
Git revision: f12fcaf4707ab436bee2df6263eb5333197b262c
Build date: 2015-02-01 21:06:05-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Mac OS X 10.10.0
Darwin Jatin66s-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 4 Rui Marinho 2015-02-13 12:01:42 UTC
Thanks, this should be fixed in 1.3.5-pre1.
Comment 5 Ram Chandra 2015-02-18 10:26:25 UTC
I have checked this issue with Xamarin.Forms: 1.3.5.6333 pre1 and I am not getting this behavior.

This issue has been fixed. Hence I am closing this issue.