Bug 26551 - 1.3.1 - "Can't install to iPad" - "Wrong Droid Error"?
Summary: 1.3.1 - "Can't install to iPad" - "Wrong Droid Error"?
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-29 12:37 UTC by Ian
Modified: 2015-05-19 07:26 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Ian 2015-01-29 12:37:36 UTC
When trying to build from XStudio Mac to an iPad device I get this strange error "Wrong Droid Error":

?????




/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" -installdev "/Users/ivink/Desktop/Main/CSI/CSI.iOS/bin/iPhone/Debug/CSIiOS.app" "--devname=CFI QA Team iPad"
Please ensure your device is connected...

error MT1006: Could not install the application '/Users/ivink/Desktop/Main/CSI/CSI.iOS/bin/iPhone/Debug/CSIiOS.app' 
on the device CFI QA Team iPad: Wrong Droid Error (error: 0xe8000028).
The application was terminated by a signal: SIGHUP
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-19 07:26:45 UTC
This error code comes from Apple's libraries (kAMDWrongDroidError), and generally indicates some problem between the Mac and the device (outside of Xamarin.iOS' control).

Try rebooting the device, the Mac, and replugging the cables and see if that helps.

Also check if you can deploy using Xcode (my guess is that the problem will affect Xcode as well).