Bug 26356 - Unable to Activate xamarin.mac
Summary: Unable to Activate xamarin.mac
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Activation ()
Version: Master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-01-23 14:25 UTC by Michael Stonis
Modified: 2015-01-23 15:12 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Michael Stonis 2015-01-23 14:25:45 UTC
I am trying to activate my license of xamarin mac, but I receive the following error.

I have double-checked all of my configurations and keys and everything looks good. Tried install twice and received same result.

error MM9014: Activation failed: DataError (Invalid activation data). Please contact support@xamarin.com

failed to suspend thread 0xb0503000, hopefully it is dead
failed to suspend thread 0xb02ff000, hopefully it is dead
failed to suspend thread 0xb0503000, hopefully it is dead
failed to suspend thread 0xb02ff000, hopefully it is dead
failed to suspend thread 0xb0503000, hopefully it is dead
Comment 1 Chris Hamons 2015-01-23 14:27:27 UTC
Michael,

Please contact http://support.xamarin.com instead of filing a bug. They can look into your license and will escalate with engineering if necessary. You'll get much better turn around instead of going through bugzilla.
Comment 2 Michael Stonis 2015-01-23 14:31:15 UTC
Can do.

I logged it here in addition because the "failed to suspend thread..." lines shows up about 5000+. It seemed like there might have been a bug related to activation.
Comment 3 Chris Hamons 2015-01-23 14:32:19 UTC
I agree. It does sounds like a possible bug. I just want to get your issue sorted as as soon as possible.
Comment 5 Michael Stonis 2015-01-23 15:12:48 UTC
Looks like it was the universal installer that has this issue. I downloaded the current release version of Xamarin.Mac (1.10.0.18) and everything installed without issue.