Bug 26269 - When we set new WebView for Activities main content, the activities view goes blank
Summary: When we set new WebView for Activities main content, the activities view goes...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Mac OS
: Highest normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-22 03:48 UTC by Prashant Cholachagudda
Modified: 2015-05-19 14:45 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (62.22 KB, application/zip)
2015-01-22 03:59 UTC, Prashant Cholachagudda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Prashant Cholachagudda 2015-01-22 03:48:15 UTC
When customer exit the application(using the back button on Android) and re-launch the application, the Webview on the Main activity goes blank.

Steps to reproduce:

- Compile and Run TestWebViewExample application on Android target. 
- Launch the application. Start Up page is displayed.
- Press the back button. Re-launch the application.
- Blank Page is displayed instead of Start Up page.

Please find below information regarding the implementation approach.

- TestWebViewExample (Android Application), uses library 'Framework' to show the startup page.
- Framework is a class library which uses Portable library called 'FrameworkPortable' to show the startup page.
- For initializing Webview, loading start up page, FrameworkPortable library contains interface IMyWebView, which is implemented by Android library 'PlatfromImpl'.
Comment 1 Prashant Cholachagudda 2015-01-22 03:59:34 UTC
Created attachment 9442 [details]
Test case
Comment 2 Udham Singh 2015-01-22 05:37:05 UTC
I have checked this issue with the help of test case attached in comment 1 and observed the same behaviour mentioned in bug description. To check this issue I have followed the steps provided in bug description. Please refer the screencast : http://www.screencast.com/t/W1RFnpuCfXm7

Application Output : https://gist.github.com/Udham1/d8276b8cfdb19f61a092
Ide Log : https://gist.github.com/Udham1/0e3d2fed9d88ea00d237
Adb Logcat : https://gist.github.com/Udham1/cef1dbfd347efb50046c

Environment Info : 

Xamarin.Forms : 1.3.1.6296

=== Xamarin Studio ===

Version 5.7.1 (build 13)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.1.9 (Business Edition)
Hash: d8e6436
Branch: 
Build date: 2015-01-18 17:38:20-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/xamarin76/Desktop/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.12.0.4 (Business Edition)

=== Build Information ===

Release ID: 507010013
Git revision: 8e357d6be321e716f361ebc9591e4cee7f217c21
Build date: 2015-01-15 14:23:22-05
Xamarin addins: a6842a7727f64e956f942b8160f7835c9d9076a4

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin76s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 3 Michael 2015-05-19 14:45:41 UTC
I have confirmed with the attached sample project and Xamarin.Forms 1.4.2

1. The start-up page is shown on launch.
2. Back button pressed (Android back button)
3. re-open app through app manager
4. The start-up page is shown