Bug 26253 - Android XF ScrollView.Position should probably be in dip coordinates like Position.Height etc.
Summary: Android XF ScrollView.Position should probably be in dip coordinates like Pos...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-21 17:21 UTC by philip
Modified: 2016-03-16 01:33 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description philip 2015-01-21 17:21:15 UTC
Under Android, ScrollView.Height etc use device independent (DIP) coordinates.  ScrollView.Position seems to be the only property that is in pixels and it should probably be provided in DIP coordinates like everything else.
Comment 1 Abhishek 2015-05-06 15:03:09 UTC
I have tried this issue but unable to reproduce the reported behavior at my end.

Steps To Reproduce:
1. Create an Xamarin.Forms PCL Application.
2. Add ContentPage File to the solution.
3. Add the scrollview code to the Xaml file.
4. Run the application on Emulator.

Could you please provide us test case along with the bug. So that I can reproduce the reported behavior at my end.

Also provide us IDE log, Build Output,Android Device Log, Environment Info.

For VS:
IDE log via Help->Xamarin->Zip Xamarin Logs.
Environment Info via Help->About Microsoft Visual Studio.

For XS:
IDE Log via Help->Open Log Directory 
Build Output via and View->Pads->Errors.
Environment Info via Help->About->Show Details.

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
 
Xamarin   3.11.507.0 (dfac85e)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.
 
Xamarin.Android   5.1.0.127 (cbdf025e886eacb95ce7adf53346961156fae990)
Visual Studio plugin to enable development for Xamarin.Android.
 
Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.
 
Xamarin.iOS   8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
Visual Studio extension to enable development for Xamarin.iOS.
 
Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified
 
Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 2 philip 2015-05-06 15:14:13 UTC
I think this issue is already fixed so we can consider it closed.
Comment 3 Samantha Houts [MSFT] 2016-03-16 01:33:48 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team