Bug 2623 - Public Override Unhandled Exception
Summary: Public Override Unhandled Exception
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.9.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-12-23 01:56 UTC by Dean
Modified: 2012-05-03 10:08 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Dean 2011-12-23 01:56:30 UTC
Using:

Mono 2.10.8.1
MT 5.1.1
MD 2.9.1

In my Main.cs whenever I create a public override I get an Unhandled Exception. System.InvalidCastException

It doesn't matter what the override is, all of them cause this problem

And then MD closes. adding a standard public void works fine.

Regards,
Dean Harry
Comment 1 Sebastien Pouliot 2011-12-23 09:06:47 UTC
You mean in the MonoDevelop editor right ? i.e. not when compiling or running the result. I had similar "close on exception" using 2.9.1.
Comment 2 Dean 2011-12-23 14:57:53 UTC
Hi Sebastian,

Yes,I worked that out last night, it's in MD. I went back to 2.8.5 and that works fine.
Comment 3 Mike Krüger 2012-05-03 10:08:59 UTC
Works on newer builds.