Bug 26196 - Linker causing crashes
Summary: Linker causing crashes
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-01-20 06:21 UTC by martinalderson
Modified: 2017-08-23 21:37 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
linkerpleaseinclude.cs (1.71 KB, text/plain)
2015-01-20 09:57 UTC, martinalderson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description martinalderson 2015-01-20 06:21:52 UTC
The linker is causing crashes on our project. This only happens on Android, with the proper LinkerPleaseInclude settings. iOS with the same settings causes problems.

It may be our configuration but it seems to work better or worse depending on the Xamarin studio version we have installed.
Comment 1 martinalderson 2015-01-20 06:24:31 UTC
That should be causes no problems. It works flawlessly on iOS.
Comment 2 Atin 2015-01-20 09:05:23 UTC
I have tried this issue but unable to reproduce this issue at my end.

If you get a chance, could you please attach Test sample application with a small testcase. 
Also add IDE Log, Application Output and environment info. 
You will find these details via:
1. IDE log: Help-> Open Log Directory.
2. Environment info:  Help-> About-> Show Details-> Copy Information.

Thanks!
Comment 3 Jonathan Pryor 2015-01-20 09:53:14 UTC
> This only happens on Android, with the proper LinkerPleaseInclude settings.

What are "LinkerPleaseInclude settings"?
Comment 4 martinalderson 2015-01-20 09:56:41 UTC
Attached the cs file to hint to the linker. This builds on iOS.

It has problems in the core MonoDroid assemblies.
Comment 5 martinalderson 2015-01-20 09:57:09 UTC
Created attachment 9415 [details]
linkerpleaseinclude.cs
Comment 6 Jonathan Pryor 2015-01-20 11:41:24 UTC
What are your linker flags for the project: Link SDK Only or Full?

> It has problems in the core MonoDroid assemblies.

Which members are being linked away?

Would it be possible to get a full repro project?
Comment 7 Cody Beyer (MSFT) 2017-08-23 21:37:53 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!