Bug 26077 - Extend Loaded Assemblies functionality
Summary: Extend Loaded Assemblies functionality
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Windows
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-15 14:01 UTC by Jon Douglas [MSFT]
Modified: 2016-04-08 18:54 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Jon Douglas [MSFT] 2015-01-15 14:01:42 UTC
*Description

I've seen a few people contact support on this issue, and that is the functionality of using an iOS class library to house all of their custom Forms controls. However there is a limitation that Xamarin.Forms only looks at Loaded Assemblies and therefore one must initialize the class to get it loaded in memory. This is somewhat confusing to customers as we only have a few resources on where this is explained.

1) At the end of the Custom Renderer video: https://www.youtube.com/watch?v=55r1wHdOLBo#t=2432

2) Via Mark Smith in this forum post: https://forums.xamarin.com/discussion/17998/custom-renderer-in-ios

*Customer Description

I’m under impression that since we have given the reference of an implemented library to IOS app, it should load assembly when the app loads. But it doesn't and we are forced to load the assembly manually by some dummy implementation. Xamarin team should consider this as a bug and I’m hoping this should be resolved in future release

Because of this, one must manually "Init" their custom class before calling Forms.Init()

public static class CustomControls
{
public static void Init() { }
}

*Xamarin.Forms Version

1.3.1.6296
Comment 1 Adam Kemp 2015-03-11 14:05:58 UTC
See also:
https://bugzilla.xamarin.com/show_bug.cgi?id=22408

There's no good way to keep an assembly from being removed from a build, and there should be.