Bug 26059 - Getting build error with latest ReactiveUI package.
Summary: Getting build error with latest ReactiveUI package.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other ()
Version: Master
Hardware: PC Mac OS
: Normal normal
Target Milestone: 2.0.x
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-01-15 07:08 UTC by Ram Chandra
Modified: 2015-03-02 08:48 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Chris Hamons 2015-02-23 13:56:59 UTC
This works for me in both master and stable.

Due to another bug, you will need to edit the csproj to point to something like this:

    <Reference Include="ReactiveUI">
      <HintPath>..\packages\reactiveui-core.6.4.0.1\lib\MonoMac\ReactiveUI.dll</HintPath>
    </Reference>

    <Reference Include="Splat">
      <HintPath>..\packages\Splat.1.6.0\lib\MonoMac\Splat.dll</HintPath>
    </Reference>

instead of net45 for those packages.
Comment 2 Parmendra Kumar 2015-03-02 08:48:43 UTC
I have checked this issue and now its working fine at my end.

Screencast: http://www.screencast.com/t/9s6oBEOKFZT

Hence I am going to close this issue.

Environment info:

ReactiveUI (6.4.0.1)

=== Xamarin Studio ===

Version 5.8 (build 1033)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 4.0.0 ((detached/2634099)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000017

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.9.1.397 (Business Edition)
Hash: 016fd4e
Branch: master
Build date: 2015-02-26 19:15:06-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 1.13.1.397 (Business Edition)

=== Build Information ===

Release ID: 508001033
Git revision: e8120ebd0c9ee45a83e48ae431e65797c172403f
Build date: 2015-02-26 13:09:22-05
Xamarin addins: e88a2212bb7156a42ad6728b82e99846c3eea817

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64