Bug 2592 - No way to set default start page when web application is started
Summary: No way to set default start page when web application is started
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: ASP.Net ()
Version: 2.8.4.1
Hardware: All All
: Low enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-20 20:14 UTC by Mike Christensen
Modified: 2015-09-18 11:10 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 2592 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Mike Christensen 2011-12-20 20:14:44 UTC
Right now, when running a web application, the web browser is opened up and navigates to the default document (/).

Under "Run->XSP Web Server", there should be a textbox that allows users to define the default URL to be run when the application starts.

Furthermore, I should be able to right click on a web page in the solution explorer and select "Set as start page" to set this value as well.