Bug 25676 - iPad TabbedPage Hides under tab in Landscape
Summary: iPad TabbedPage Hides under tab in Landscape
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-31 16:29 UTC by Ian
Modified: 2015-05-19 15:23 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Phone (102.82 KB, image/png)
2014-12-31 16:29 UTC, Ian
Details
iPad (123.14 KB, image/png)
2014-12-31 16:29 UTC, Ian
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Ian 2014-12-31 16:29:26 UTC
Created attachment 9222 [details]
Phone

I have attached 2 images, both landscape. XForms 1.2.3

The iPhone correctly puts the content visible (WebView), but the iPad hides the bottom of the webview under the tabs at the bottom. The page is scrollable, but it should behave like the iPhone.

Portrait works fine in both iPhone and iPad.
Comment 1 Ian 2014-12-31 16:29:44 UTC
Created attachment 9223 [details]
iPad
Comment 2 Udham Singh 2015-01-02 04:18:15 UTC
Hi Ian,

It would be easy to reproduce this issue, if you share the sample project that demonstrate this issue if possible.

Also include your environment info. You can get environment info via 'Xamarin Studio ->About Xamarin Studio ->Show Details ->Copy Information and paste it here.'

Thanks!
Comment 9 Jason Smith [MSFT] 2015-05-19 15:23:52 UTC
This happens if you put a TabbedPage inside a NavigationPage.

Place the NavigationPage inside the TabbedPage to avoid this problem. This is an issue with UITabbarController and UINavigationController on iOS.