Bug 25652 - UIStoryboard file does not copy and the build fails saying file not found
Summary: UIStoryboard file does not copy and the build fails saying file not found
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 5.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-30 08:06 UTC by Pruthvi
Modified: 2015-01-05 07:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Logs (5.50 KB, application/octet-stream)
2014-12-30 08:06 UTC, Pruthvi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Pruthvi 2014-12-30 08:06:59 UTC
Created attachment 9207 [details]
Logs

In my app I created a Storyboard (CustomerSearch.storyboard) with two view controllers. While trying to build the app, build fails with the following error:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Cannot copy /Users/Srinidhi/Desktop/workspace/XAMARIN/XAMARIN_iOS_Sample_Project/iOS/obj/iPhoneSimulator/Debug/ibtool/CustomerSearch.storyboardc to /Users/Srinidhi/Desktop/workspace/XAMARIN/XAMARIN_iOS_Sample_Project/iOS/bin/iPhoneSimulator/Debug/UnviredIOSSample.app/CustomerSearch.storyboardc, as the source file doesn't exist. (UnviredIOSSample)

But the storyboard file exists in the file system and I am able to view the properties as well as edit them. Find the attached Storyboard in question which should help you to resolve the issue faster.
Comment 1 Udham Singh 2014-12-30 10:23:19 UTC
I have checked this issue and able to reproduce this. To reproduce this issue I have followed the steps mentioned below.

1. Create a simple iOS application(Unified API - iPhone Single View).
2. Add the attached storyboard file (bug description) in app.
3. Build the project and got the issue.

Screencast : http://www.screencast.com/t/ZxeLTkKu

Error Log : https://gist.github.com/Udham1/a3a11e51a954ceae4ebe
Ide Log : https://gist.github.com/Udham1/822a85ff2c7fd9e3b9b2
Build Output Log : https://gist.github.com/Udham1/a77f87c62ff7155db066
iOS Designer Log : https://gist.github.com/Udham1/39fd427113c600f26112

Environment Info :

=== Xamarin Studio ===

Version 5.5.4 (build 15)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.10.0 ((detached/92c4884)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000031

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.4.0.47 (Enterprise Edition)
Hash: 7244769
Branch: 
Build date: 2014-12-11 14:54:30-0500

=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

=== Operating System ===

Mac OS X 10.9.4
Darwin Xamarin76s-Mac-mini.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-01-05 04:59:10 UTC
@Udham, can you please try with the beta channel and see if it still happens there?
Comment 3 Udham Singh 2015-01-05 07:01:03 UTC
Hi Rolf,

I have checked this issue with current beta channel builds and observed that this issue has been fixed.

Hence closing this issue. 

Environment Info :

Mac OS X 10.9.4
Xamarin Studio 5.7 (build 660)
Mono 3.10.0 ((detached/92c4884)
GTK+ 2.24.23 (Raleigh theme)
Xcode 6.1.1 (6611)
Xamarin.iOS  8.6.0.41 (Enterprise Edition)

=== Build Information ===

Release ID: 507000660
Git revision: 6a74f9bdb90d9415b597064d815c9be38b401fee
Build date: 2014-12-18 00:38:00-05
Xamarin addins: 57be0f5e1433cb58b70ea9b52e9dc77ad791be40