Bug 25622 - [Android] Form disappears in WebView on Lollypop
Summary: [Android] Form disappears in WebView on Lollypop
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.0
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-27 00:48 UTC by Artur Shamsutdinov
Modified: 2015-05-19 13:26 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Form before focus is set (77.31 KB, image/png)
2014-12-27 00:48 UTC, Artur Shamsutdinov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Artur Shamsutdinov 2014-12-27 00:48:44 UTC
Created attachment 9190 [details]
Form before focus is set
Comment 4 Rajneesh Kumar 2014-12-29 05:42:21 UTC
I have checked this issue and able to reproduce this. To reproduce this issue I have followed the help and instruction provided in bug description.

Steps I followed:

1. Open attached test application in XS.
2. Set android as startup project.
3. Build and deploy it on Nexus 5 device.
4. It deploy successfully, and shows a sign-In view.
5. Click on textbox to enter email.
6. Observed that all content disappears.

Additional Information: With Samsung s5 not able to reproduce this issue, its working fine. 

==Supplement Info==
Screencast: http://www.screencast.com/t/XZjCcZVN9
screenshot(Device): http://www.screencast.com/t/QIURZYy3MGQ 
Device Log: https://gist.github.com/Rajneesh360Logica/7a2d6ec08747bc0e3cc8
Ide Logs: http://www.screencast.com/t/YF0Vw0xJZr0C
Application Output: https://gist.github.com/Rajneesh360Logica/c5c753942f120cdb0e63
Build output: https://gist.github.com/Rajneesh360Logica/2a7dde03306626b78ede

Please let me know if I can provide more useful information from my side.

Environment Info:

=== Xamarin Studio ===
Version 5.5.4 (build 15)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.10.0 ((detached/92c4884)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000031

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.4.0.47 (Business Edition)
Hash: 7244769
Branch: 
Build date: 2014-12-11 14:54:30-0500

=== Xamarin.Mac ===

Version: 1.10.0.18 (Business Edition)

=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 6 Seth Rosetter 2015-03-20 21:08:23 UTC
This issue is resolved in 1.4.0
Comment 7 Rajneesh Kumar 2015-05-19 13:26:05 UTC
I have checked this issue with the following builds:

Xamarin.Forms Version: 1.4.2.6359
Xamarin Studio Version 5.9.2 (build 2)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
Mono 4.0.1 ((detached/11b5830)
GTK+ 2.24.23 (Raleigh theme)
Package version: 400010043
Xamarin.Android Version: 5.1.2.0 (Trial Edition)
Java SDK: /usr
java version "1.7.0_65"
Build Information 
Release ID: 509020002
Git revision: 43735a4b905b571f69cf9428a3ea7b52aef55476
Build date: 2015-05-18 09:38:12-04
Xamarin addins: ab18ddff45f507ed74f36c2b65df9aee22e28a56
=== Operating System ===
Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
Sun Aug 17 19:50:11 PDT 2014
 root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64

I observed that this issue has been fixed and working fine. Now the content of webpage content does't disappears when user clicks on text-boxes. 
Screenshot(Images): http://www.screencast.com/t/224hXxDZ
Screencast: http://www.screencast.com/t/ytvbYYK6Mdo4

This issue does not exist now hence I am closing this issue.

Thanks..!