Bug 25564 - 3.9.221.0: Linker options resets to Link All Assemblies everytime property pages are reopened
Summary: 3.9.221.0: Linker options resets to Link All Assemblies everytime property pa...
Status: RESOLVED DUPLICATE of bug 26308
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.9
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-21 19:05 UTC by softlion
Modified: 2015-07-16 16:55 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26308

Description softlion 2014-12-21 19:05:22 UTC
beta 3.9.221.0: 
Linker options resets to Link All Assemblies everytime the property page is reopened, even if the value is changed to anything else.
This is very annoying.
Comment 1 narayanp 2014-12-29 10:17:40 UTC
I have tried to reproduce this issue and getting the same behavior. Linker options resets to "Link All Assemblies" everytime when the property page is reopened.

Screencast: http://screencast.com/t/ZRp0O8xqQhyb
IDE log: https://gist.github.com/sunil360/1890046f421c7e29ad59

Environment info: 
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Xamarin   3.9.221.0 (a6d269d)
Xamarin.Android   4.20.0.34 (49a04b966feb40dfdba49d57ba16249b66d606a6)
Xamarin.iOS   8.6.0.0 (43e3b715220b50914b45bec675e19008ff50682a)

Build host info: 
X.iOS 8.6.0.45
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-16 16:55:31 UTC
Thanks for the report. By chance there was a duplicate report where this ended up getting fixed.

I will now mark this bug a duplicate of that bug to help tidy up the list of open bugs.

*** This bug has been marked as a duplicate of bug 26308 ***