Bug 25523 - XA app crashes on startup when “Use Shared Mono runtime" with RuntimeException
Summary: XA app crashes on startup when “Use Shared Mono runtime" with RuntimeException
Status: CLOSED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.20.0
Hardware: PC Mac OS
: Highest normal
Target Milestone: ---
Assignee: Radek Doulik
URL:
Depends on:
Blocks:
 
Reported: 2014-12-19 05:34 UTC by Prashant Cholachagudda
Modified: 2015-01-15 06:51 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Comment 2 Jonathan Pryor 2014-12-19 10:12:08 UTC
@Radek: Didn't you see an error like this recently?
Comment 4 Radek Doulik 2015-01-14 14:53:46 UTC
Sandeep, could you please attach a diagnostic msbuild output? See http://developer.xamarin.com/guides/android/troubleshooting/troubleshooting/

It looks like the Mono.Android.Platform.ApiLevel_21 package wasn't properly installed. The diagnostic output might contain some info why it is happening.
Comment 5 Sandeep 2015-01-15 04:53:31 UTC
Radek and Xamarin team, this bug seems to be resolved in Xamarin Studio 5.7.
I've been using it for a week now and haven't hit the issue so far.
This can be closed now.
Comment 6 Radek Doulik 2015-01-15 05:35:01 UTC
Thanks for the info.
Comment 7 Akhilesh kumar 2015-01-15 06:51:32 UTC
As per comment 5, now user is not able to replicate this issue.

So I am closing this issue.