Bug 25363 - TabbedPage - Blows up if child page has bad image
Summary: TabbedPage - Blows up if child page has bad image
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-13 14:26 UTC by Ian
Modified: 2016-03-25 18:59 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Ian 2014-12-13 14:26:53 UTC
this.Children.Add(new NotesPage() {Title = "Notes", Icon = "bad.png"});

Error:

     in system.linq.enumerable.select<xamarin.forms.visualelement, xamarin.forms.rectangle> 
    at     
      //library/frameworks/xamarin.ios.framework/versions/8.4.0.43/src/mono/mcs/class/system.core/system.linq/enumerable.cs:2262,-1 c#
Comment 1 Ram Chandra 2015-01-02 05:10:28 UTC
I have checked this issue but I am unable to reproduce this behavior.

I have write the following code and observed that my application is working fine without any error.

>tabs.Children.Add (new BasicListPage {Title="Basic", Icon = "csharp.png" });

Screencast: http://www.screencast.com/t/hKja6hqnb

Could you please provide sample application, environment information and logs (build  output + IDE logs). So that we can reproduce this behavior at our end.

You can get build information form here:
Visual Studio =>HELP => About Microsoft Visual Studio => Copy Info 

You can get IDE logs form here:  
Visual Studio=> HELP => Zip Xamarin Logs (attached the logs)

For Build Output:
Visual Studio => View => Output

Environment Info: 

Windows Info:
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin   3.8.150.0 (10cfd178d55287f09c85f5a1e604dfe20889a40f)
Xamarin.Android   4.20.0.28 (ba9bbbdd44cfdc4bf485e8885bd2ad24fba525f7)
Xamarin.iOS   8.4.0.0 (840a925103a0bf4a856507f13d5eaee3c1579c2f)


Mac Info:
Mac OS X 10.9.5
Xamarin Studio: 5.5.4 (build 15)
Mono 3.10.0 ((detached/92c4884)
GTK+ 2.24.23 (Raleigh theme)
Package version: 310000031
Xamarin.Android: 4.20.0.28 (Business Edition)
Xcode 6.1 (6604)
Build 6A1052d
Xamarin.iOS: 8.4.0.47 (Business Edition)
=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8
Comment 2 Jason Smith [MSFT] 2016-03-25 18:59:29 UTC
No reproduction